AUR web interface

**This is the bug tracker for the AUR web interface.**

Use this tracker to report bugs or make feature requests regarding the behaviour or implementation of the AUR software.
Please read the Reporting Bug Guidelines before filing a new task.
https://wiki.archlinux.org/title/Bug_reporting_guidelines

- Please report bugs related to Arch Linux official packages here: http://bugs.archlinux.org/index.php?project=1
- Please report bugs for [community] packages here: http://bugs.archlinux.org/index.php?project=5
- For any packages in the AUR contact the maintainer or leave a comment on the package's detail page.

Source Code:
https://gitlab.archlinux.org/archlinux/aurweb/
Tasklist

FS#45443 - [AUR 4] link AUR package "providing" a dependency rather than defaulting to (normal) package search

Attached to Project: AUR web interface
Opened by Johannes Dewender (JonnyJD) - Tuesday, 23 June 2015, 21:56 GMT
Last edited by Lukas Fleischer (lfleischer) - Wednesday, 24 June 2015, 10:55 GMT
Task Type Feature Request
Category Backend
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version 4.0.0-rc3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Some dependencies are not satisfied with a package with the same name, but with a "provides" from a package with a different name.

example:
https://aur4.archlinux.org/packages/lib32-ffmpeg/
depends=("lib32-libx264")
is satisfied with
https://aur4.archlinux.org/packages/lib32-libx264-stable-git/
provides=("lib32-libx264")

The dependency "lib32-libx264" is linked to a search in the official repository:
https://www.archlinux.org/packages/?q=lib32-libx264
where it is not found (since there is no such package in the official repository).

For official packages we link all packages where a dependency is provided:
https://www.archlinux.org/packages/extra/x86_64/ffmpeg/
libx264.so=144-64 (libx264, libx264-10bit)

I would like if we do that on AUR 4, too.
Otherwise there is no connection (in neither direction) between lib32-ffmpeg and lib32-libx264-stable-git.
This task depends upon

Closed by  Lukas Fleischer (lfleischer)
Wednesday, 24 June 2015, 10:55 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Dupe of  FS#14125 .

Loading...