Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#45440 - makepkg runs `mkdir pkg` twice failing the second time

Attached to Project: Pacman
Opened by Danny Arnold (despairblue) - Tuesday, 23 June 2015, 19:09 GMT
Last edited by Dave Reisner (falconindy) - Tuesday, 23 June 2015, 19:26 GMT
Task Type Bug Report
Category makepkg
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version 4.2.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Summary and Info:
makepkg runs `mkdir pkg` twice, failing the second time, since it's already there. This leads to:
```
==> Entering fakeroot environment...
mkdir: cannot create directory ‘/home/despairblue/git/synergy/pkg/’: File exists
/usr/bin/fakeroot: line 181: 3529 User defined signal 1 FAKEROOTKEY=$FAKEROOTKEY LD_LIBRARY_PATH="$PATHS" LD_PRELOAD="$LIB" "$@"
```

Steps to Reproduce:
Use that PKGBUILD: https://gist.github.com/despairblue/21b7cde32497c7e151d5
I also put `set -x` on top of the PKGBUILD and included the log. When you search backwards for `mkdir` it becomes apparent what happens.
This task depends upon

Closed by  Dave Reisner (falconindy)
Tuesday, 23 June 2015, 19:26 GMT
Reason for closing:  Not a bug
Comment by Danny Arnold (despairblue) - Tuesday, 23 June 2015, 19:12 GMT
Nevermind, I accidentally commented out the pkgname -.-

Loading...