Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45431 - [git] Add optdepend on perl-cgi for gitweb

Attached to Project: Arch Linux
Opened by John Lindgren (jlindgren) - Tuesday, 23 June 2015, 12:43 GMT
Last edited by Christian Hesse (eworm) - Wednesday, 02 August 2017, 05:59 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Dan McGee (toofishes)
Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:

git should optionally depend on perl-cgi for gitweb. Else lighttpd produces the following error:

Can't locate CGI.pm in @INC (you may need to install the CGI module) (@INC contains: /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl .) at /usr/share/gitweb/gitweb.cgi line 13.

Additional info:
* package version(s)
git 2.4.4-1
lighttpd 1.4.35-2

Steps to reproduce:
Set up gitweb with lighttpd as described here: https://wiki.archlinux.org/index.php/Gitweb#Lighttpd
This task depends upon

Closed by  Christian Hesse (eworm)
Wednesday, 02 August 2017, 05:59 GMT
Reason for closing:  Fixed
Additional comments about closing:  Changed in SVN, will be available in next package.
Comment by Jonathan Ryan (jryan) - Tuesday, 22 March 2016, 18:41 GMT
Any updates for this? It's been a while.
Comment by Simon Wydooghe (HyperBaton) - Friday, 02 December 2016, 10:49 GMT
I can confirm this. Lost some time trying to figure out why an error 500 was occurring...
Comment by Jonathan Ryan (jryan) - Friday, 02 December 2016, 11:53 GMT
Anyone? I filed this in June of 2015...

Loading...