Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45243 - [linux] Kernel 4.0.5-1-ARCH show vertical purple line and blurry on HDMI output using AMD Radeon

Attached to Project: Arch Linux
Opened by Irvan Kurniawan (sourc7) - Sunday, 07 June 2015, 12:52 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 25 August 2015, 14:39 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
This problem were solved on previous same HDMI Audio bug (https://bugs.archlinux.org/task/44915), after I upgraded to Kernel 4.0.5-1-ARCH the purple line and blurry output is reappears, At Kernel 4.0.5 changelog indicate the Kernel re-enable the HDMI Audio if the monitor support it (Revert "drm/radeon: only mark audio as connected if the monitor supports it (v3)"), but it still has a same bug.

Run this command on will solve the problem: xrandr --output HDMI-0 --auto --set audio off

Additional info:
* hardware info
- AMD Radeon HD7770
- Samsung S22D300 (HDMI without sound output)

* package version(s)
- linux (4.0.5-1)
- xf86-video-ati (1:7.5.0-2)

* config and/or log files etc.
- Kernel and Xorg log with HDMI connection
- Photo indicates the purple line and blurry problem

Steps to reproduce:
Upgrade to the latest Linux kernel (4.0.5-1) then connect the display that doesn't support audio using the HDMI connection to AMD Radeon HD7770's HDMI connector
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 25 August 2015, 14:39 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux 4.1.6-1
Comment by Irvan Kurniawan (sourc7) - Monday, 08 June 2015, 00:51 GMT
To disable the Radeon HDMI audio at boot, append "radeon.audio=0" on kernel boot parameters
Comment by Irvan Kurniawan (sourc7) - Friday, 26 June 2015, 03:54 GMT
I already tested the new Linux Kernel 4.0.6 but the problem is still occured, temporary fix using above method.

Loading...