Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45196 - [filesystem] make use of sysusers.d instead of static files to maintain system users/groups

Attached to Project: Arch Linux
Opened by Tom Yan (tom.ty89) - Thursday, 04 June 2015, 05:32 GMT
Last edited by Sébastien Luttringer (seblu) - Sunday, 10 December 2017, 16:05 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Sébastien Luttringer (seblu)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

Description:
Currently the filesystem package shipped static passwd/group/shadow/gshadow files and use some checking/updating functions to maintain a list of system users and groups including the systemd specific ones; meanwhile the systemd package also make use of systemd-sysusers in the install files. Could Arch completely switch to sysusers.d? It seems to me it would be much more neat that way. While the systemd package can ship a list of users to avoid some unwanted deps, other packages can also shipped their own specific confs and trigger the update (instead of creating them with useradd/groupadd in the install files).

Reminder for you to update filesystem later if you guys don't give a damn on this idea (as expected): currently systemd-journal-remote and systemd-journal-upload are not in filesystem in are required/created by systemd.

P.S. From what I've test (in cleaning up the filesystem package), dbus and uuidd are the only users/groups which is essential in Arch but not created by the upstream confs. Actually, just by the way, the bin/lib symlinks seems to be the only essential things in the filesystem package, many other stuff are either unnecessary or should be maintained in other specific package (or already are).


Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Sébastien Luttringer (seblu)
Sunday, 10 December 2017, 16:05 GMT
Reason for closing:  Implemented
Additional comments about closing:  filesystem 2017.10-2
Comment by Sébastien Luttringer (seblu) - Sunday, 26 March 2017, 22:04 GMT
moved uuidd and dbus to their respective packages and removed from filesystemd in 2017.03-2
Comment by Gustavo Alvarez (sl1pkn07) - Thursday, 30 March 2017, 13:29 GMT Comment by Konstantin Gizdov (kgizdov) - Saturday, 01 April 2017, 19:34 GMT
I am wondering as the user here - am I supposed to remove those lines form the files manually?
Comment by userwithuid (userwithuid) - Sunday, 02 April 2017, 15:54 GMT
@Konstantin: No, systemd would just add them again.

@all:
Should sysusers.d be used to replace useradd/groupadd in .install files for all Arch packages not just filesystem? New TODO list?
Comment by Bruno Pagani (ArchangeGabriel) - Monday, 03 April 2017, 18:04 GMT
@userwithuid: I think it should. It’s already done for numerous packages, and we now have the hook to handle this without even having an .install file.
Comment by Sébastien Luttringer (seblu) - Wednesday, 30 August 2017, 23:55 GMT
Now in trunk. A test package is available here: http://pkgbuild.com/~seblu/filesystem-2017.08-0.3-x86_64.pkg.tar.xz.

Loading...