Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45151 - [kodi] Segfault in llvm::ConstantExpr::getBitCast when playing most videos with software rendering

Attached to Project: Community Packages
Opened by Dan Ziemba (zman0900) - Saturday, 30 May 2015, 23:07 GMT
Last edited by Ike Devolder (BlackEagle) - Wednesday, 22 July 2015, 20:56 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Ike Devolder (BlackEagle)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
With the update to 14.2-4, kodi now crashes when trying to play most videos. I can't seem to find any pattern of which audio, video, or container type causes the crash. I was able to prevent the crashes by enabling video acceleration with vdpau (using radeonsi driver). The crash shown in the log always seems to be the same:

Program terminated with signal SIGSEGV, Segmentation fault.
#0 0x00007f78824129a0 in llvm::ConstantExpr::getBitCast(llvm::Constant*, llvm::Type*, bool) () from /usr/lib/libLLVM-3.6.so


Additional info:
* package version(s)
kodi 14.2-4
llvm 3.6.1-1
ffmpeg 1:2.6.3-2
mesa 10.5.6-1

* config and/or log files etc.
Full crash log attached.


Steps to reproduce:
- In kodi, go to Settings -> Video -> Acceleration
- Set Deconding method to Software
- Attempt to play videos until one causes a crash
This task depends upon

Closed by  Ike Devolder (BlackEagle)
Wednesday, 22 July 2015, 20:56 GMT
Reason for closing:  Fixed
Additional comments about closing:  uses internal ffmpeg again
Comment by Ike Devolder (BlackEagle) - Sunday, 31 May 2015, 07:26 GMT
It looks like this is a very specific crash linked to the radeon xorg driver.

I cannot reproduce this when I choose software on an nvidia gpu system.

There will be a new version 14.2-5 for the hvec playback issue, maybe you get some different result with thatone.
Comment by Dan Ziemba (zman0900) - Tuesday, 09 June 2015, 20:56 GMT
New version 14.2-5 didn't fix software rendering. That is with all packages up to date as of sometime last night. You're probably right that this is just some bug with the radeonsi driver. The end of the log suggests that it is using shaders to render the video:

16:48:24 T:140205539366848 NOTICE: Using GL_TEXTURE_2D
16:48:24 T:140205539366848 NOTICE: GL: Selecting Single Pass YUV 2 RGB shader
16:48:24 T:140205539366848 NOTICE: GL: NPOT texture support detected
16:48:24 T:140205539366848 NOTICE: GL: Using GL_ARB_pixel_buffer_object

Or maybe it could be a bug in ffmpeg that happens to effect both the built in version the current kodi package uses and the system version the previous package version used. Luckily, vdpau acceleration is working quite well recently so I don't need software rendering.

Loading...