Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45117 - [mkinitcpio] base hook take rootfstype param instead of fstype

Attached to Project: Arch Linux
Opened by Tom Yan (tom.ty89) - Thursday, 28 May 2015, 11:35 GMT
Last edited by Dave Reisner (falconindy) - Sunday, 03 July 2016, 18:23 GMT
Task Type General Gripe
Category Arch Projects
Status Closed
Assigned To Thomas B├Ąchler (brain0)
Dave Reisner (falconindy)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Currently mkinitcpio takes (only) the boot param "fstype" instead of "rootfstype" as documented in kernel docs. I am not sure if it's documented in mkinitcpio but I wonder if it's necessary to make such a difference, since it takes rootflags, which is documented in kernel docs as well.


Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Dave Reisner (falconindy)
Sunday, 03 July 2016, 18:23 GMT
Reason for closing:  Fixed
Additional comments about closing:  mkinitcpio-20-1
Comment by dx (dx) - Sunday, 29 May 2016, 00:03 GMT
Ran into this one and wasted plenty of time trying to figure out what i did wrong.

Here's a trivial patch which fixes it, a straightforward rename, which hopefully gets this ticket fixed.
Comment by Dave Reisner (falconindy) - Sunday, 03 July 2016, 17:58 GMT
This is fixed in git as:

https://git.archlinux.org/mkinitcpio.git/commit/?id=14487ea9a6104c17b00c6fa7bcb65c617c7490c8

I opted to leave in support for fstype for backwards compat.

Loading...