Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45105 - [systemd] v220 crypt swap regression

Attached to Project: Arch Linux
Opened by c (c) - Wednesday, 27 May 2015, 09:31 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 27 May 2015, 17:14 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I had to downgrade to systemd 219 because 220 fails to stop or enable
luks crypt swap partition.

There was an unlogged error on shutdown after upgrade and
an infinite loop/wait with animation on startup.

I had to use a rescue linux to mount and disable the crypttab and fstab
entries before downgrading.

/etc/crypttab:
cswap /dev/sda3 /dev/urandom swap,cipher=aes-cbc-essiv:sha256,size=256

/etc/fstab:
/dev/mapper/cswap none swap defaults 0 0

Found nothing relevant about API breakage in v220 changelog.

I've seen #45086 but that sounds like a different bug.

https://lists.archlinux.org/pipermail/arch-general/2015-May/thread.html#39208

Steps to reproduce:
Upgrade, reboot.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Wednesday, 27 May 2015, 17:14 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#45086 
Comment by Doug Newgard (Scimmia) - Wednesday, 27 May 2015, 14:00 GMT
I'm pretty sure this is the same as  FS#45086 , the key is just generated automatically instead of being entered.
Comment by Doug Newgard (Scimmia) - Wednesday, 27 May 2015, 17:14 GMT
New package with a fix for  FS#45086  is in the works. If it doesn't fix this, request that this be reopened.

Loading...