Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45100 - [libreoffice-fresh] [libreoffice-still] libsdlo.so error without avahi installed

Attached to Project: Arch Linux
Opened by Darrell Ostrom (0strodamus) - Tuesday, 26 May 2015, 20:41 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 26 May 2015, 22:44 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: This error affects both libreoffice-fresh 4.4.3-1 and libreoffice-still 4.3.7-1 packages. When the avahi package is not installed, launching Draw fails and generates an "loading component library <file:///usr/lib/libreoffice/program/../program/libsdlo.so> failed" error. Launching Impress fails with no error.

I have found three solutions:
1- install the avahi package
2- manually overwrite the /usr/lib/libreoffice/program/libsdlo.so file with the file from the AUR libreoffice-fresh-rpm 4.4.3-1 package
3- recompiling the packages with --disable-avahi

ldd /usr/lib/libreoffice/program/libsdlo.so
libavahi-common.so.3 => not found
libavahi-client.so.3 => not found

Avavhi is not a dependency of libreoffice-fresh or libreoffice-still, so I'm not sure why it is needed for Draw and Impress to function. Thanks in advance for any help.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 26 May 2015, 22:44 GMT
Reason for closing:  Not a bug
Comment by Karol Błażewicz (karol) - Tuesday, 26 May 2015, 21:06 GMT
ldd lists linked libraries recursively. Use readelf -d to list direct dependencies only.

One package dependency chain is: gtk2 depends on libcups which in turn depends on avahi.
Comment by Darrell Ostrom (0strodamus) - Tuesday, 26 May 2015, 21:42 GMT
Thanks for the information. I'm using a libcups 2.0.2-4 package that I compiled with --disable-avahi. Does this mean that I'll have to compile libreoffice myself from now on if I don't want to install avahi? My apologies for logging a bug report if that is the case.
Comment by Doug Newgard (Scimmia) - Tuesday, 26 May 2015, 22:43 GMT
Pretty much. Since it's already in the dependency chain, there's nothing to be done here. Once you change a package, it essentially becomes unsupported.

Loading...