Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45074 - [devtools] makechrootpkg does not support XDG_CONFIG_DIR/pacman/makepkg.conf

Attached to Project: Arch Linux
Opened by sjung (tummychow) - Sunday, 24 May 2015, 20:24 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 19 July 2016, 15:31 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Pierre Schmitz (Pierre)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
As title. makepkg supports a user configuration file in $XDG_CONFIG_DIR/pacman/makepkg.conf, but makechrootpkg doesn't source it. It only sources ~/.makepkg.conf and /etc/makepkg.conf, so configuration variables in the XDG_CONFIG_DIR location do not get passed to the chroot.

Additional info:
- devtools version 20150514-1
- pacman version 4.2.1-1

Steps to reproduce:
- echo 'PKGDEST=/tmp' > ~/.config/pacman/makepkg.conf
- try to build a package with makechrootpkg
- the package will not end up in /tmp because .config/pacman/makepkg.conf was not sourced
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 19 July 2016, 15:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  https://git.archlinux.org/devtools.git/c ommit/?id=e3fe7134e2f8d99770226e7a8a7a07 cbf106883b

Loading...