Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#45039 - [iniparser] memory corruption

Attached to Project: Arch Linux
Opened by Christian Hesse (eworm) - Thursday, 21 May 2015, 08:18 GMT
Last edited by Evangelos Foutras (foutrelis) - Tuesday, 30 June 2015, 07:50 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I have random bad behavior. This is caused by a memory allocation missing string termination. Prepared a patch [0] und sent upstream [1].

[0] https://github.com/eworm-de/iniparser/commit/3d385e4f2aba5122d9e40481c4aec9135b96428a
[1] https://github.com/ndevilla/iniparser/pull/52

Additional info:
iniparser 4.0-1
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Tuesday, 30 June 2015, 07:50 GMT
Reason for closing:  Fixed
Additional comments about closing:  iniparser 4.0-2
Comment by Christian Hesse (eworm) - Thursday, 21 May 2015, 17:40 GMT Comment by Christian Hesse (eworm) - Thursday, 18 June 2015, 07:05 GMT
Any reason we do not see a fixed package?

Loading...