Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44994 - [msmtp] TLS handshake failed, build against gnutls

Attached to Project: Arch Linux
Opened by Arthur Heymans (victini) - Sunday, 17 May 2015, 15:02 GMT
Last edited by Eli Schwartz (eschwartz) - Wednesday, 09 August 2017, 04:34 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Eric Belanger (Snowman)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: msmtp: TLS handshake failed: the operation timed out

msmtp fails to connect with a standard postfix smtp server with the error message: msmtp: TLS handshake failed: the operation timed out

I found a solution: http://sourceforge.net/p/msmtp/mailman/message/32440857/
which is to build msmtp against openssl instead of gnutls. I can confirm that is works.

Maybe change PKGBUILD?
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Wednesday, 09 August 2017, 04:34 GMT
Reason for closing:  Fixed
Additional comments about closing:  msmtp 1.6.3 appears to no longer have this issue
Comment by Malte Milatz (maltem) - Wednesday, 06 January 2016, 20:19 GMT
Can confirm; it was quite difficult to figure out what the problem was (does nobody use postfix these days?).

Upstream doesn't seem to prefer either openssl or gnutls, so changing the PKGBUILD would look sensible to me.
Comment by Malte Milatz (maltem) - Tuesday, 19 January 2016, 14:22 GMT
This appears to be fixed in 1.6.3.

Loading...