Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44946 - [vlc] lublua_plugin.so corrupted

Attached to Project: Arch Linux
Opened by Chih-Hsuan Yen (yan12125) - Tuesday, 12 May 2015, 14:50 GMT
Last edited by Anatol Pomozov (anatolik) - Tuesday, 12 May 2015, 17:44 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Giovanni Scafora (giovanni)
Anatol Pomozov (anatolik)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
When I'm starting vlc from the command line, I got some warnings and errors about liblua_plugin.so: (lines irrelevant are stripped)

$ vlc -v
VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42)
(...some other warnings about missing plugins...)
[0000000001033aa8] core demux meta warning: cannot load module `/usr/lib/vlc/plugins/lua/liblua_plugin.so' (/usr/lib/vlc/plugins/lua/liblua_plugin.so: undefined symbol: luaL_openlib)
[0000000001033aa8] core demux meta error: corrupt module: /usr/lib/vlc/plugins/lua/liblua_plugin.so
[0000000000f33118] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[00007f4be42544b8] core generic warning: cannot load module `/usr/lib/vlc/plugins/lua/liblua_plugin.so' (/usr/lib/vlc/plugins/lua/liblua_plugin.so: undefined symbol: luaL_openlib)
[00007f4be42544b8] core generic error: corrupt module: /usr/lib/vlc/plugins/lua/liblua_plugin.so
[00000000010701c8] qt4 interface error: Unable to load extensions module

Recently lua is updated to 5.3 and published to [testing]. It might be the cause?

Additional info:
$ yaourt -Q lua vlc
testing/lua 5.3.0-1
testing/vlc 2.2.1-4

Steps to reproduce:
Enable [testing] repo and install the packages listed above. And then start VLC.
This task depends upon

Closed by  Anatol Pomozov (anatolik)
Tuesday, 12 May 2015, 17:44 GMT
Reason for closing:  Fixed
Additional comments about closing:  lua-5.3.0-2
Comment by Anatol Pomozov (anatolik) - Tuesday, 12 May 2015, 15:48 GMT
luaL_openlib function has been deprecated in 5.2. In 5.3 this function is not compiled in (by default).

I am going to rebuild vlc with Lua 5.2. It also a good idea to post this error to VLC maillist/bugtracker.
Comment by Chih-Hsuan Yen (yan12125) - Tuesday, 12 May 2015, 16:07 GMT
I'm not sure where to post the bug report. Seems http://trac.videolan.org/vlc is the bug tracker. However, it's not accessible from my place. Can anyone familiar with VLC development forward this bug?
Comment by Anatol Pomozov (anatolik) - Tuesday, 12 May 2015, 16:08 GMT
It looks like maillist is the only option https://mailman.videolan.org/listinfo/vlc-devel
Comment by Anatol Pomozov (anatolik) - Tuesday, 12 May 2015, 16:22 GMT
Instead of vlc rebuild I enabled lua 5.1 compatibility mode in lua-5.3.0-2 package. This allows to migrate apps to lua5.3 smoothly. VLC should be fixed now.

It is still a good idea to contact upstream and let them know they use ancient lua5.1 API. Ideally they should use only lua5.3 API (i.e. no LUA_COMPAT_* macroses).
Comment by Chih-Hsuan Yen (yan12125) - Tuesday, 12 May 2015, 16:34 GMT
Thanks for the great work! Also, I've sent a report to vlc-devel.

Loading...