Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44845 - [nettle] libnettle.so.4 missing, but my pacman seems to need it

Attached to Project: Arch Linux
Opened by Ruben Kelevra (RubenKelevra) - Monday, 04 May 2015, 11:05 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 04 May 2015, 13:02 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After some updates my pacman dies with

# pacman -S
pacman: error while loading shared libraries: libnettle.so.4: cannot open shared object file: No such file or directory

A link of the libnettle.so.6 to the libnettle.so.4 fixes the issue. A reinstall of nettle and pacman packages does not.


Additional info:
* package version(s)
# pacman -Qi pacman nettle | grep -E "^Name|^Version"
Name : pacman
Version : 4.2.1-1
Name : nettle
Version : 3.1.1-1

Steps to reproduce:
Dunno, this is the only affected system.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 04 May 2015, 13:02 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Monday, 04 May 2015, 13:02 GMT
"After some updates" doesn't tell us anything.

Partial updates are not supported. You upgrade your entire system or you upgrade nothing.

Loading...