Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.

FS#4481 - Coloring..

Attached to Project: Pacman
Opened by Desislav (Insane-Boy) - Wednesday, 19 April 2006, 10:58 GMT
Last edited by Roman Kyrylych (Romashka) - Wednesday, 24 January 2007, 11:33 GMT
Task Type Feature Request
Status Closed
Assigned To Aaron Griffin (phrakture)
Architecture not specified
Severity Very Low
Priority Normal
Reported Version 0.7.1 Noodle
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I think It'll be good to colored packages from extra/testing/current and other with colors.Examply if there is a package from current on page which shows deps or on -Ss page It'll be red ( examply.. )..In my opinion It'll be a nice new feature because some of us want stable system only from packages which are in current or in extra and if you have add server with testing pkgs you will not know which packages are testing and which are stable ( if you want to ugprade them ).
This task depends upon

Closed by  Aaron Griffin (phrakture)
Wednesday, 24 January 2007, 16:08 GMT
Reason for closing:  Deferred
Additional comments about closing:  It is the general consensus that used provided scripts (see bbs link) are the proper way to do this.

I know a lot of people "complain" about color and all, but it's easily doable without a codebase change.
Comment by Jürgen Hötzel (juergen) - Thursday, 20 April 2006, 19:10 GMT
Seems to be a dup of  FS#1273 . This should be implemented in external programs. There are some nice examples:


Comment by Desislav (Insane-Boy) - Friday, 21 April 2006, 10:23 GMT
Yes but it's only for -Ss.I want to see which packages are from extra/current/testing/unstable/community when i search/catch deps/ ...