Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44799 - [systemd] systemd 219-6 + linux 4.0.1-1 = journal failing to append on boot

Attached to Project: Arch Linux
Opened by brent saner (sanerb) - Friday, 01 May 2015, 08:36 GMT
Last edited by Dave Reisner (falconindy) - Thursday, 30 July 2015, 05:55 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Thomas B├Ąchler (brain0)
Dave Reisner (falconindy)
Tom Gundersen (tomegun)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
in some cases (i can't seem to narrow down which yet), tmpfiles fails to create /run/log/journal. This then causes further failure of journald to fail to both:

-append to the volatile journal
-append to the persistent journal (if one exists)- no flushes, as the volatile journal is not appended

the volatile journal does not exist because it normally is written to /run/log/journal. on boot, the entries of /run/log/journal are copied over to the persistent journal in /var/log/journal/ (if persistence is enabled), from what i understand.


/usr/lib/tmpfiles.d/systemd.conf has the following:


d /run/log 0755 root root -

z /run/log/journal 2755 root systemd-journal - -
Z /run/log/journal/%m ~2750 root systemd-journal - -

a+ /run/log/journal/%m - - - - d:group:adm:r-x,d:group:wheel:r-x
A+ /run/log/journal/%m - - - - group:adm:r-x,group:wheel:r-x


I'm not familiar enough with the tmpfiles.d syntax to determine if this is correct or not, but the same install layout was working on 3.19.3-3-ARCH kernel.
This task depends upon

Closed by  Dave Reisner (falconindy)
Thursday, 30 July 2015, 05:55 GMT
Reason for closing:  Upstream
Comment by brent saner (sanerb) - Friday, 01 May 2015, 08:43 GMT
wasn't sure what y'all would want, but just let me know which files you want or command output and i'll attach.

additionally, this only seems to happen on my desktop, not my laptop (that i can tell.)
Comment by brent saner (sanerb) - Friday, 01 May 2015, 08:44 GMT
(though /run/log/journal is not created on my laptop either... yet it *is* created on my firewall box.)
Comment by brent saner (sanerb) - Friday, 01 May 2015, 08:50 GMT
temporary workaround is running:

systemctl restart systemd-journald

at least gets it logging to /var/log/journal again. however, it still doesn't seem to log to /run/log/journal as the dir is never created.
Comment by zed (zeltak) - Friday, 01 May 2015, 10:35 GMT
i can confirm the same exact bug using arch linux on a X1 carbon 3rd gen

best

zeltak
Comment by Dave Reisner (falconindy) - Friday, 01 May 2015, 13:45 GMT
The mentioned tmpfiles.d lines have nothing to do with directory creation, only setting ACLs. systemd-journald takes care of creating /run/log/journal itself, through code.

Nothing to do with Arch packaging here. Please sort out whether this is a systemd bug or a kernel bug and report it to the appropriate upstream.
Comment by brent saner (sanerb) - Friday, 01 May 2015, 14:31 GMT Comment by brent saner (sanerb) - Sunday, 31 May 2015, 08:42 GMT
requesting closure. this appears to be due to /var being on a separate device/partition, and/or also as a bind mount.

Loading...