Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#4467 - cups is not starting (keeps being [busy])

Attached to Project: Arch Linux
Opened by Damir Perisa (damir.perisa) - Sunday, 16 April 2006, 11:16 GMT
Task Type Bug Report
Category Packages: Current
Status Closed
Assigned To No-one
Architecture not specified
Severity Critical
Priority Normal
Reported Version 0.7.1 Noodle
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

the day before yesterday i did a -Suy ... with the following actions:

[04/14/06 19:05] synchronizing package lists
[04/14/06 19:05] starting full system upgrade
[04/14/06 19:33] removed mawk (1.3.3-6)
[04/14/06 19:36] installed gawk (3.1.5-2)
[04/14/06 19:36] upgraded abiword-plugins (2.4.1-1 -> 2.4.3-1)
[04/14/06 19:36] upgraded autoconf (2.59-1 -> 2.59-2)
[04/14/06 19:37] upgraded clamav (0.88-1 -> 0.88.1-1)
[04/14/06 19:38] upgraded control-center (2.14.0-2 -> 2.14.1-1)
[04/14/06 19:38] upgraded dcraw (1.320-1 -> 1.323-1)
[04/14/06 19:39] installed perl-event (1.06-1)
[04/14/06 19:39] installed perl-anyevent (1.02-1)
[04/14/06 19:39] installed perl-event-execflow (0.61-1)
[04/14/06 19:39] upgraded dvdrip (0.97.6-1 -> 0.97.7-1)
[04/14/06 19:39] upgraded eel (2.14.0-1 -> 2.14.1-1)
[04/14/06 19:39] upgraded libsoup (2.2.7-3 -> 2.2.92-1)
[04/14/06 19:40] upgraded evolution-data-server (1.6.0-1 -> 1.6.1-1)
[04/14/06 19:40] upgraded file-roller (2.14.0-1 -> 2.14.1-1)
[04/14/06 19:41] upgraded foomatic-db-ppd (20060326-1 -> 20060411-1)
[04/14/06 19:41] upgraded gedit (2.14.1-2 -> 2.14.2-1)
[04/14/06 19:42] upgraded gnome-backgrounds (2.14.0-1 -> 2.14.1-1)
[04/14/06 19:42] upgraded gnome-desktop (2.14.0-1 -> 2.14.1-1)
[04/14/06 19:43] upgraded gnome-games (2.14.0-1 -> 2.14.1-2)
[04/14/06 19:44] upgraded gnome-panel (2.14.0-1 -> 2.14.1-1)
[04/14/06 19:45] upgraded gnome-session (2.14.0-2 -> 2.14.1-1)
[04/14/06 19:46] upgraded gnome-system-monitor (2.14.0-1 -> 2.14.1-1)
[04/14/06 19:47] upgraded gnome-terminal (2.14.0-1 -> 2.14.1-1)
[04/14/06 19:48] upgraded gnome2-user-docs (2.8.1-1 -> 2.14.2-1)
[04/14/06 19:48] upgraded gtksourceview (1.6.0-1 -> 1.6.1-1)
[04/14/06 19:49] upgraded kernel26 (2.6.16.2-1 -> 2.6.16.4-1)
[04/14/06 19:51] upgraded koffice (1.4.2-5 -> 1.5.0-2)
[04/14/06 19:51] upgraded laptop-mode-tools (1.29-1 -> 1.30-1)
[04/14/06 19:52] upgraded libast (0.6.1-3 -> 0.7-1)
[04/14/06 19:52] upgraded libgnome (2.14.0-1 -> 2.14.1-1)
[04/14/06 19:53] upgraded libgnomeui (2.14.0-1 -> 2.14.1-1)
[04/14/06 19:53] upgraded libgphoto2 (2.1.6-6 -> 2.1.99-1)
[04/14/06 19:53] upgraded libgtop (2.13.92-1 -> 2.14.1-1)
[04/14/06 19:53] upgraded libraw1394 (1.2.0-1 -> 1.2.1-1)
[04/14/06 19:54] upgraded libwnck (2.14.0-1 -> 2.14.1-1)
[04/14/06 19:54] installed mawk (1.3.3-7)
[04/14/06 19:54] upgraded metacity (2.14.1-2 -> 2.14.2-1)
[04/14/06 19:55] upgraded nautilus (2.14.0-1 -> 2.14.1-1)
[04/14/06 19:56] upgraded nautilus-cd-burner (2.14.0.2-1 -> 2.14.1-1)
[04/14/06 19:57] upgraded newt (1.08-1 -> 1.08-2)
[04/14/06 19:57] upgraded php (5.1.2-1 -> 5.1.2-3)
[04/14/06 19:57] upgraded poppler (0.5.1-1 -> 0.5.1-2)
[04/14/06 19:58] upgraded pygtk (2.8.4-1 -> 2.8.5-1)
[04/14/06 19:58] upgraded slang (1.4.9-1 -> 2.0.6-1)
[04/14/06 19:58] upgraded subversion (1.3.0-2 -> 1.3.1-1)
[04/14/06 19:59] upgraded sysvinit (2.86-1 -> 2.86-2)
[04/14/06 19:59] upgraded udev (089-2 -> 089-3)
[04/14/06 19:59] upgraded xaos (3.2-1 -> 3.2-2)
[04/14/06 20:00] upgraded yelp (2.14.0-1 -> 2.14.1-1)
[04/14/06 20:00] upgraded zenity (2.14.0-1 -> 2.14.1-1)

then yesterday cups took much longer to start (about 10 minutes) but it came up.

today cups is not comming up but keeps saying "[busy]" now already more than 3 hours long.

here cups/error_log entries:

from a normal startup from some days ago:
I [13/Apr/2006:12:06:54 +0200] Listening to 0:631
I [13/Apr/2006:12:06:54 +0200] Loaded configuration file "/etc/cups/cupsd.conf"
I [13/Apr/2006:12:06:55 +0200] Configured for up to 100 clients.
I [13/Apr/2006:12:06:55 +0200] Allowing up to 100 client connections per host.
I [13/Apr/2006:12:06:55 +0200] Full reload is required.
I [13/Apr/2006:12:06:58 +0200] LoadPPDs: Read "/etc/cups/ppds.dat", 1521 PPDs...
I [13/Apr/2006:12:06:59 +0200] LoadPPDs: No new or changed PPDs...
I [13/Apr/2006:12:07:00 +0200] Full reload complete.
I [13/Apr/2006:12:07:01 +0200] Started filter /usr/lib/cups/filter/pstops (PID 3798) for job 404.
I [13/Apr/2006:12:07:01 +0200] Started filter /usr/lib/cups/filter/foomatic-rip (PID 3799) for job 404.
I [13/Apr/2006:12:07:01 +0200] Started backend /usr/lib/cups/backend/parallel (PID 3800) for job 404.
I [13/Apr/2006:12:47:16 +0200] Scheduler shutting down normally.

from the strange longtaking start:
I [15/Apr/2006:22:20:16 +0200] Listening to 0:631
I [15/Apr/2006:22:20:16 +0200] Loaded configuration file "/etc/cups/cupsd.conf"
I [15/Apr/2006:22:20:16 +0200] Configured for up to 100 clients.
I [15/Apr/2006:22:20:16 +0200] Allowing up to 100 client connections per host.
I [15/Apr/2006:22:20:16 +0200] Full reload is required.
I [15/Apr/2006:22:20:18 +0200] LoadPPDs: Read "/etc/cups/ppds.dat", 1521 PPDs...
I [15/Apr/2006:22:23:13 +0200] LoadPPDs: Wrote "/etc/cups/ppds.dat", 179681 PPDs...
I [15/Apr/2006:22:23:16 +0200] Full reload complete.
I [15/Apr/2006:22:23:17 +0200] Started filter /usr/lib/cups/filter/pstops (PID 4628) for job 404.
I [15/Apr/2006:22:23:17 +0200] Started filter /usr/lib/cups/filter/foomatic-rip (PID 4629) for job 404.
I [15/Apr/2006:22:23:17 +0200] Started backend /usr/lib/cups/backend/parallel (PID 4630) for job 404.
I [16/Apr/2006:02:00:05 +0200] Scheduler shutting down normally.

(note the now 179681 PPDs instead of 1521)

and now it does not start fully but keeps saying [busy] with this in the log:
I [16/Apr/2006:13:02:34 +0200] Listening to 0:631
I [16/Apr/2006:13:02:34 +0200] Loaded configuration file "/etc/cups/cupsd.conf"
I [16/Apr/2006:13:02:34 +0200] Configured for up to 100 clients.
I [16/Apr/2006:13:02:34 +0200] Allowing up to 100 client connections per host.
I [16/Apr/2006:13:02:34 +0200] Full reload is required.
I [16/Apr/2006:13:02:50 +0200] LoadPPDs: Read "/etc/cups/ppds.dat", 179681 PPDs...

and it stays at that i guess it keeps trying to load all this 180k PPDs that do not exist...

i had to remove cups from DAEMONS and now i have no printing in linux -> severity critical

i guess it has something to do with foomatic-db-ppds
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Sunday, 23 April 2006, 13:14 GMT
Reason for closing:  Fixed
Comment by Damir Perisa (damir.perisa) - Sunday, 16 April 2006, 11:47 GMT
i had a look at the file
/etc/cups/ppds.dat

and it looks very strange... i don't know how it should look like, but it should not look like this:

[damir@Asteraceae ~]$ more /etc/cups/ppds.dat
AlpsAlps MD-1000 Foomatic/md2k
ÁX£;Dfoomatic/ppd/Alps/Alps-MD-1000-md2k.ppd
enAlps
Alps MD-1000 Foomatic/md2k
ÁX£;Dfoomatic/foomatic/ppd/Alps/Alps-MD-1000-md2k.ppd
enAlpsAlps MD-1000 Foomatic/md2k
ÁX£;Dfoomatic/foomatic/foomatic/ppd/Alps/Alps-MD-1000-md2k.ppd
enAlps
Alps MD-1000 Foomatic/md2k
ÁX£;Dfoomatic/foomatic/foomatic/foomatic/ppd/Alps/Alps-MD-1000-md2k.ppd
enAlpsAlps MD-1000 Foomatic/md2k
ÁX£;Dfoomatic/foomatic/foomatic/foomatic/foomatic/ppd/Alps/Alps-MD-1
00-md2k.ppdenAlps
Alps MD-1000 Foomatic/md2k
ÁX£;Dfoomatic/foomatic/foomatic/foomatic/foomatic/foomatic/ppd/Alps/Alps-MD-1000-md2k.ppd
enAlpsAlps MD-1000 Foomatic/md2k
ÁX£;Dfoomatic/foomatic/foomatic/foom
tic/foomatic/foomatic/foomatic/ppd/Alps/Alps-MD-1000-md2k.ppdenAlps
Alps MD-1000 Foomatic/md2k
ÁX£;Dfoomatic/foomatic/foomatic/foomatic/foomatic/foomatic/foomatic/foomatic/ppd/Alps/Alps-MD-1000-md2k.ppd
enAlps
Alps MD-1000 Foomatic/md2kÁX£;
foomatic/foomatic/foomatic/foomatic/foomatic/foomatic/foomatic/foomatic/foomatic/ppd/Alps/Alps-MD-1000-md2k.ppd
enAlpsAlps MD-1000 Foomatic/md2k
ÁX£;Dfoomatic/foomatic/foomatic/foomatic/foomatic/foomatic/foomatic/foomatic/foomatic/foomatic/ppd/Alps/Alps-MD-1000
md2k.ppdenAlps
Alps MD-1000 Foomatic/md2k
ÁX£;Dfoomatic/foomatic/foomatic/foomatic/foomatic/foomatic/foomatic/foomatic/foomatic/foomatic/foomatic/ppd/Alps/Alps-MD-
1000-md2k.penAlps
...

seems that somewhere something is a cyclic link... and /etc/cups/ppds.dat is more than 100MB big

does somebody have an idea how to fix this and rebuild ppds.dat?
Comment by Damir Perisa (damir.perisa) - Sunday, 16 April 2006, 12:07 GMT
ok, i found out what the problem was and a solution:

[root@Asteraceae foomatic]# pwd
/usr/share/foomatic
[root@Asteraceae foomatic]# ls -la
total 10
drwxr-xr-x 5 root root 152 2006-04-16 14:03 .
drwxr-xr-x 331 root root 9656 2006-04-15 00:19 ..
drwxr-xr-x 3 root root 104 2006-03-30 23:21 db
lrwxrwxrwx 1 root root 19 2003-12-30 17:17 foomatic -> /usr/share/foomatic
drwxr-xr-x 51 root root 1264 2006-04-14 19:41 ppd
drwxr-xr-x 2 root root 168 2006-03-30 23:21 templates

this cyclic link was the problem

i rm'ed it, rm'ed the /etc/cups/ppds.dat, killed all cups instances + the daemon and then started cups daemon... the output:

I [16/Apr/2006:14:02:24 +0200] Listening to 0:631
I [16/Apr/2006:14:02:24 +0200] Loaded configuration file "/etc/cups/cupsd.conf"
I [16/Apr/2006:14:02:24 +0200] Configured for up to 100 clients.
I [16/Apr/2006:14:02:24 +0200] Allowing up to 100 client connections per host.
I [16/Apr/2006:14:02:24 +0200] Full reload is required.
I [16/Apr/2006:14:02:27 +0200] LoadPPDs: Wrote "/etc/cups/ppds.dat", 5975 PPDs...
I [16/Apr/2006:14:02:31 +0200] Full reload complete.
I [16/Apr/2006:14:02:31 +0200] Started filter /usr/lib/cups/filter/pstops (PID 5669) for job 404.
I [16/Apr/2006:14:02:31 +0200] Started filter /usr/lib/cups/filter/foomatic-rip (PID 5670) for job 404.
I [16/Apr/2006:14:02:31 +0200] Started backend /usr/lib/cups/backend/parallel (PID 5671) for job 404.

[root@Asteraceae ~]# /daemons/cups start
:: Starting CUPS Daemon [DONE]

ok ... what i forgot to check is where this cyclic link came from (pacman -Qo /usr/share/foomatic/foomatic ), so please, if somebody out there is in the same situation, first check who owns this cyclic link before you remove it ;-)

i leave this bug open, as this rm and rebuild of ppds.dat is a workaround... we should fix it in the pkg(s) causing it...
Comment by Tobias Powalowski (tpowa) - Tuesday, 18 April 2006, 14:29 GMT
this endless loop was caused by db-foomatic-ppd i fixed the package that it doesn't create the loop anymore some time ago.
Comment by Damir Perisa (damir.perisa) - Tuesday, 18 April 2006, 22:35 GMT
does your fix also remove the wrong link? because this link existed stil on my fs in the newest foomatic-db-ppd and it did not belong to any pkg as far i remember... no... i forgot to check.

Loading...