Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44646 - [kompare] we can not select files

Attached to Project: Arch Linux
Opened by patrick (potomac) - Sunday, 19 April 2015, 17:19 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 27 August 2015, 22:59 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
after upgrading to kompare 15.04.0-2 package I notice a weird bug :

the GUI only allows directories to be selected, that means we can not select files, which is silly, because the purpose of kompare is to compare 2 files, and not 2 directories



Additional info:
* package version(s) kompare 15.04.0-2
* config and/or log files etc.


Steps to reproduce:

- run kompare 15.04.0-2
- try to select a file
- you will notice that you can't select a file, only directories are allowed in the GUI
This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 27 August 2015, 22:59 GMT
Reason for closing:  Fixed
Additional comments about closing:  kompare 15.08.0-2
Comment by Antonio Rojas (arojas) - Sunday, 19 April 2015, 17:22 GMT
Please report upstream
Comment by patrick (potomac) - Sunday, 19 April 2015, 17:29 GMT
Antiono Rojas : can you confirm you have also this bug ?

could it be a package problem or a mismatch version for QT5 libraries ?
Comment by patrick (potomac) - Sunday, 19 April 2015, 18:56 GMT
other options in kompare menus who use the "filesave dialog box" have the same problem ( for example the menu "file --> save Diff", we can not press the "save" button )
Comment by Antonio Rojas (arojas) - Sunday, 19 April 2015, 19:26 GMT
No, this looks like a Qt5 porting issue. In any case, it's not a packaging issue.
Comment by Yama (YamashitaRen) - Wednesday, 22 April 2015, 15:20 GMT
Hello patrick, I can confirm that I have this bug too.
Comment by daimonion (demon) - Wednesday, 03 June 2015, 15:48 GMT
There are several Kompare and libkomparediff2 patches (master branch) which made kompare 15.04 somewhat usable, but maintainer seems to be lazy to backport them. I'm not sure if any of those patches solve this problem, but still I think it's worth to include them:

https://git.reviewboard.kde.org/r/123697/
https://git.reviewboard.kde.org/r/123696/
https://git.reviewboard.kde.org/r/123698/
https://git.reviewboard.kde.org/r/123767/
https://git.reviewboard.kde.org/r/123776/
Comment by Antonio Rojas (arojas) - Sunday, 23 August 2015, 10:00 GMT
what's the status with 15.08? Did you report it upstream?
Comment by Yama (YamashitaRen) - Sunday, 23 August 2015, 13:59 GMT
Bug is NOT fixed in 15.08.
Just used Kompare, files were indeed listed. Couldn't select them.
Then I looked in the "filetype" chooser, only "directories" is available. After that, files aren't listed anymore.
Will report it upstream asap.
Comment by patrick (potomac) - Sunday, 23 August 2015, 14:18 GMT
the bug is not fixed with 15.08, still the same problem
Comment by patrick (potomac) - Tuesday, 25 August 2015, 16:29 GMT
I tried to rebuild the package 15.08 with the patches given by daimonion but it doesn't solve the problem, in fact most of these patches are already in 15.08, it seems that these patches don't have a link with the main problem ( the fact that we can't select files in the GUI )

I tried also the git version of kompare, the bug is still here
Comment by patrick (potomac) - Tuesday, 25 August 2015, 19:06 GMT
I did some investigations on source code of kompare, and I get some informations,

I found a workaround by changing 2 lines in main.cpp file :

original lines ( lines 231 and 232 )

dialog.setFirstURLRequesterMode( KFile::File|KFile::Directory|KFile::ExistingOnly );
dialog.setSecondURLRequesterMode( KFile::File|KFile::Directory|KFile::ExistingOnly );

my changes :

dialog.setFirstURLRequesterMode( KFile::File||KFile::Directory|KFile::ExistingOnly );
dialog.setSecondURLRequesterMode( KFile::File||KFile::Directory|KFile::ExistingOnly );

I set an "OR" with "||" instead a "|" between "KFile::File" and "KFile::Directory",

another solution :

dialog.setFirstURLRequesterMode( KFile::File|KFile::ExistingOnly );
dialog.setSecondURLRequesterMode( KFile::File|KFile::ExistingOnly );

here I simply delete "KFile::Directory" in order to be sure that files can be selected,

my patch works, but I am not sure if it's the best solution
Comment by patrick (potomac) - Tuesday, 25 August 2015, 19:07 GMT
here is the patch
Comment by patrick (potomac) - Tuesday, 25 August 2015, 19:20 GMT
the second version of my patch, I prefer this to the first version
Comment by Antonio Rojas (arojas) - Tuesday, 25 August 2015, 21:26 GMT
Nice, but posting patches here is not going to help fixing the bug. Once again: this needs to be reported upstream
Comment by Yama (YamashitaRen) - Wednesday, 26 August 2015, 07:03 GMT Comment by patrick (potomac) - Thursday, 27 August 2015, 13:23 GMT

Loading...