Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44566 - [fcitx] 4.2.8.6-2: default input method not set

Attached to Project: Community Packages
Opened by Stefan Förster (HotblackDesiato) - Sunday, 12 April 2015, 22:58 GMT
Last edited by Ivy Foster (escondida) - Thursday, 17 October 2019, 16:58 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Since the latest update to version 4.2.8.6-2, fcitx no longer sets the default keyboard/ input method. I have a German keyboard and thus my default IM in fcitx is "Keyboard - German". In XFCE4 my keyboard setting is "German" (no other keyboard besides that). My second IM in fcitx is "Sunpinyin". After login to XFCE4 on my desktop the default IM is an English QWERTY keyboard.

Besides that, fcitx works as expected, i.e. I can choose "Sunpinyin" and "Keyboard - German" and get the correct mapping of characters (e.g. I can type "öäüß" for German and "你好吗?" for Mandarin).

Steps to reproduce:
1. Install fcitx and xfce4
2. Set IM to non-English keyboard layout, e.g. to German.
This task depends upon

Closed by  Ivy Foster (escondida)
Thursday, 17 October 2019, 16:58 GMT
Reason for closing:  Upstream
Additional comments about closing:  https://gitlab.com/fcitx/fcitx/issues/32 4
https://gitlab.com/fcitx/fcitx/issues/43 6
Comment by Stefan Förster (HotblackDesiato) - Tuesday, 14 April 2015, 22:14 GMT
Update: After login to XFCE4 when I type in Firefox instead of the console, the font used by default is a Chinese font (for instance I get "。" instead of "."). The default IM by default is "German", but the keyboard layout is English and the font is that of "Sunpinyin".
Comment by Ivy Foster (escondida) - Thursday, 10 October 2019, 03:41 GMT
HotblackDesiato, do you still experience this issue with latest fcitx?
Comment by Stefan Förster (HotblackDesiato) - Thursday, 17 October 2019, 04:02 GMT
The problem is gone for me, since I recently installed MX Linux on my notebook due to instabilities of Arch Linux. I am not sure whether the bug still exists, I can't repro it.
Comment by Ivy Foster (escondida) - Thursday, 17 October 2019, 16:58 GMT
Possibly related to <https://gitlab.com/fcitx/fcitx/issues/324> and <https://gitlab.com/fcitx/fcitx/issues/436>. Since OP currently can't reproduce it and the issue seems to dovetail with a couple of upstream bugs, including a pretty broad one about problems with DE integration, I'm going to close this for now as "upstream".

Note: When closing the issue, highlight text/middle-click copying the URLs directly from this comment put spaces before the final number in both cases. Sorry 'bout that.

Loading...