Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#44556 - [weston - gdk] gdk-ERROR : wl_display@1: error 1: invalid arguments for xdg_shell@12.get_xdg_surface

Attached to Project: Arch Linux
Opened by Maxime de Roucy (akira86) - Sunday, 12 April 2015, 10:11 GMT
Last edited by Sébastien Luttringer (seblu) - Thursday, 04 June 2015, 00:00 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Sébastien Luttringer (seblu)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Unable to launch any gtk application inside weston.

Exact error :
(gtk3-demo:5011): Gdk-ERROR **: wl_display@1: error 1: invalid arguments for xdg_shell@13.get_xdg_surface

Additional info:
* weston 1.7.0
* gtk3 3.16.1-1

Steps to reproduce:
* launch weston
* inside weston launch a terminal
* GDK_BACKEND=wayland CLUTTER_BACKEND=wayland gtk3-demo

GDK_BACKEND & CLUTTER_BACKEND are optionnal. I get the same output without it.
I tried to launch weston inside a "gnome" session (so under Xorg) and "gnome in wayland" session → Same result.
I have no problem running gtk3-demo outside weston, under "gnome" or "gnome in wayland" sessions and with or without GDK_BACKEND & CLUTTER_BACKEND.

I also tried with gnome-calculator.

It seems maynard-git has the same error : (2015-03-11 10:41)

Is it a bug (maybe gtk3 doesn't work inside weston anymore ?) ? If it is, is it an Archlinux, a weston or gtk bug ?
This task depends upon

Closed by  Sébastien Luttringer (seblu)
Thursday, 04 June 2015, 00:00 GMT
Reason for closing:  Upstream
Additional comments about closing:  weston 1.8.0