Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44548 - gnome 3.16 fails with "Oh no! Something has gone wrong"

Attached to Project: Arch Linux
Opened by Guilherme Gonçcalves (guerch) - Saturday, 11 April 2015, 14:43 GMT
Last edited by Jan de Groot (JGC) - Friday, 03 June 2016, 12:10 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Steffens (heftig)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 18
Private No

Details

Description:
gnome 3.16 gdm fails with Gnome 3.16 "Oh no! Something has gone wrong", desktop still usable with super key

Info:

https://bbs.archlinux.org/viewtopic.php?id=195880
https://bbs.archlinux.org/viewtopic.php?id=195955
https://bbs.archlinux.org/viewtopic.php?id=195866

Steps to reproduce:
I did a fresh install + nvidia blob gtx 760 + gnome (no extras) and i was able to reproduce.
This task depends upon

Closed by  Jan de Groot (JGC)
Friday, 03 June 2016, 12:10 GMT
Reason for closing:  Fixed
Additional comments about closing:  Should be fixed with latest versions of gnome-shell and gnome-settings-daemon.

This bug contains way too much different bugs, so if you still have issues, just open a new one with backtraces included.
Comment by Doug Newgard (Scimmia) - Saturday, 11 April 2015, 16:10 GMT
Think you could have provided any LESS information?
Comment by Guilherme Gonçcalves (guerch) - Saturday, 11 April 2015, 18:48 GMT
Sorry i disappointed you Doug, instead of posting my logs, i posted the threads that many have posted their logs (perhaps a poor decision) , i am even available to re-install again following advice on how to best give feedback.
Comment by Doug Newgard (Scimmia) - Saturday, 11 April 2015, 20:07 GMT
The problem is that those threads are a mess.
Comment by Guilherme Gonçcalves (guerch) - Saturday, 11 April 2015, 20:43 GMT
I Agree, here are some attempts on my part that might help narrow it down, (i was wondering if it was GDM's fault) so i used lightdm in its place to no avail, i replaced nvidia blob with nouveau, also to no avail, my dmesg told me what i think its the best clue:
[code][ 6.944546] sound hdaudioC1D0: HDMI: invalid ELD data byte 31
[ 8.154148] gnome-settings-[664]: segfault at 20 ip 00007f10ba2d1f78 sp 00007ffc15e55830 error 6 in libglib-2.0.so.0.4400.0[7f10ba2b2000+10c000]
[ 8.284571] ISO 9660 Extensions: RRIP_1991A
[ 8.459415] gnome-settings-[965]: segfault at 20 ip 00007f5b63cadf78 sp 00007ffeca0641a0 error 6 in libglib-2.0.so.0.4400.0[7f5b63c8e000+10c000] [/code]

Based on that i re-installed gnome-settings-daemon also I tried re-installing and downgrading glib2, all to no avail.
Comment by Michael Wilson (roflmuffin) - Sunday, 12 April 2015, 02:41 GMT
I have a similar issue except the super key is not usable for me. I have no segfaults in my dmesg. I have reinstalled nvidia drivers, tried installing nouveau drivers instead, all to no avail.

The error is independent of login managers as I've tried a combination of LightDM, GDM and classic startx and I get something has gone wrong every time.

If you can tell me what other logs I could supply I will do so.

Comment by Dominik Wild (wilddom) - Sunday, 12 April 2015, 09:58 GMT
Same behaviour here:

Apr 12 09:30:07 systemd-coredump[10009]: Process 9893 (gnome-settings-) of user 1000 dumped core.
Apr 12 09:30:07 gnome-session[9604]: gnome-session[9604]: WARNING: App 'gnome-settings-daemon.desktop' respawning too quickly
Apr 12 09:30:07 gnome-session[9604]: Unrecoverable failure in required component gnome-settings-daemon.desktop
Apr 12 09:30:07 gnome-session[9604]: WARNING: App 'gnome-settings-daemon.desktop' respawning too quickly
Apr 12 09:30:07 gnome-session[9604]: gnome-session[9604]: WARNING: Application 'gnome-settings-daemon.desktop' killed by signal 11
Apr 12 09:30:07 gnome-session[9604]: WARNING: Application 'gnome-settings-daemon.desktop' killed by signal 11
Apr 12 09:30:07 kernel: gnome-settings-[9893]: segfault at 20 ip 00007f61b19e1f78 sp 00007ffdcd5e76f0 error 6 in libglib-2.0.so.0.4400.0[7f61b19c2000+10c000]
Apr 12 09:30:07 gnome-session[9604]: (gnome-settings-daemon:9893): GLib-CRITICAL **: g_variant_ref_sink: assertion 'value != NULL' failed
Apr 12 09:30:07 gnome-session[9604]: (gnome-settings-daemon:9893): GLib-CRITICAL **: g_variant_new_string: assertion 'string != NULL' failed
Apr 12 09:30:07 gnome-session[9604]: (gnome-settings-daemon:9893): GLib-CRITICAL **: g_variant_ref_sink: assertion 'value != NULL' failed
Apr 12 09:30:07 gnome-session[9604]: (gnome-settings-daemon:9893): GLib-CRITICAL **: g_variant_new_string: assertion 'string != NULL' failed
Apr 12 09:30:07 gnome-session[9604]: (gnome-settings-daemon:9893): GLib-CRITICAL **: g_variant_ref_sink: assertion 'value != NULL' failed
Apr 12 09:30:07 gnome-session[9604]: (gnome-settings-daemon:9893): GLib-CRITICAL **: g_variant_new_string: assertion 'string != NULL' failed
Comment by Lucas (tr4ce) - Monday, 13 April 2015, 12:19 GMT
I have the same problem.

In the thread it is mentioned that disconnecting a Wacom "solves" this issue, which is also the case for me. I can connect the Wacom afterwards, and use it. However, there are a few problems:

- Double click in nautilus doesn't work
- The scrollbar in nautilus (and other GNOME apps) doesn't appear when moving the mouse near the side of the window.
Comment by Guilherme Gonçcalves (guerch) - Monday, 13 April 2015, 15:06 GMT
For what i gathered, all from fresh installs:
1: as Micheal stated the bug is independent of login managers (i have tried lxdm sddm lightdm and no login manager at all, straight X into gnome-shell)
2: the bug is independent of kernel versions (i have tried latest and lts)
3: the bug happens using nvidia blob or nouveau (please if you have the same issue on AMD or INTEL please report, so far it seems to be restricted to nvidia cards)
4: i use a multimonitor setup 4 heads, i have not tested it on a single monitor (i will do it and report back here, please report your "head count" here too)
5: It's independent of file systems or restricted to ext4 or xfs, as i have tried both.
6: I wanted to eliminate user install error, even believing that i am doing all correctly, i also installed Antegros (the new iso with baked gnome 3.16) and that also fails exactly.

The wacom issue seems to be a separate issue, as i have no wacom hardware on my desktop and this issue so far has no workarounds.

Comment by Jason Stapels (jstapels) - Monday, 13 April 2015, 15:59 GMT
I have this issue on AMD...

[jstapels@bahamut ~]$ lspci
...
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series]

I am also multihead (2 monitors) and do NOT have a Wacom tablet. The last few message from the daemon are...

(gnome-settings-daemon:3941): common-plugin-DEBUG: Checking for match between ['','',''] and ['DEL','DELL U2412M','M2GCR212408L']
(gnome-settings-daemon:3941): common-plugin-DEBUG: Checking for match between ['','',''] and ['DEL','DELL U2412M','M2GCR2123WJL']
(gnome-settings-daemon:3941): common-plugin-DEBUG: Did not find a matching output for EDID ',,'
(gnome-settings-daemon:3941): common-plugin-DEBUG: Did not find a built-in monitor
(gnome-settings-daemon:3941): GLib-CRITICAL **: g_variant_new_string: assertion 'string != NULL' failed
(gnome-settings-daemon:3941): GLib-CRITICAL **: g_variant_ref_sink: assertion 'value != NULL' failed
(gnome-settings-daemon:3941): GLib-CRITICAL **: g_variant_new_string: assertion 'string != NULL' failed
(gnome-settings-daemon:3941): GLib-CRITICAL **: g_variant_ref_sink: assertion 'value != NULL' failed
(gnome-settings-daemon:3941): GLib-CRITICAL **: g_variant_new_string: assertion 'string != NULL' failed
(gnome-settings-daemon:3941): GLib-CRITICAL **: g_variant_ref_sink: assertion 'value != NULL' failed
Segmentation fault (core dumped)
Comment by Michiel Helvensteijn (mhelvens) - Monday, 13 April 2015, 17:39 GMT
I also have this problem, with a few differences:

(1) I never see any message "Oh no! Something has gone wrong" (where is this message displayed?).
(2) Some people report that they can "use the desktop with the super key". I'm not sure what this means. I never arrive in Gnome shell. I get kicked back to GDM after trying to log in.
(3) I also get a segfault in dmesg, but a *different one*:

gnome-shell[495]: segfault at 7f2c088c4258 ip 00007f2c1b1cd0c9 sp 00007fff36d426b0 error 7 in libX11.so.6.3.0[7f2c1b18b000+13b000]

I posted my journal logs here:

https://bbs.archlinux.org/viewtopic.php?pid=1519529#p1519529

I have an NVidia card with 2 monitors + 1 TV attached, but booting with just 1 monitor does not help. I have no Wacom hardware.

None of the offered workarounds have yet worked for me.
Comment by Guilherme Gonçcalves (guerch) - Monday, 13 April 2015, 18:15 GMT
Michiel, i think your issue happens before the one the rest of us are experiencing (but might still be related), the "Oh no! Something is gone wrong" is the gnome white screen of death, it's a pretty huge white window, but if you press the super key "windows key" that usually shows you your programs in gnome, and that works fine and you can launch programs, and you can "mostly" use the desktop (but you can't get rid of the huge white window).

You can also try not to use GDM to test for a display manager bug:
disable gdm sudo systemctl disable gdm
install a different display manager (lightdm), follow the wiki instructions (basically install, enable the service, reboot)
also try without a DM, use X to start your gnome.

In our case, none of that is possible, but in yours it could be, try that out and if it sticks report this bug to GDM
Comment by Michiel Helvensteijn (mhelvens) - Monday, 13 April 2015, 18:22 GMT
Hi Guilherme,

Yes, I suspected there might be two different (but perhaps related) things going on here. I still posted my info here, because the third forum topic you linked to (id=195866) describes 'my bug'. Just read Netpilgrim's original post.
Comment by Jason Stapels (jstapels) - Monday, 13 April 2015, 19:00 GMT
Just a quick gnome tip: If you Super-RightClick on the "On no!" window, you can minimize it to get rid of it till your next login.
Comment by Michiel Helvensteijn (mhelvens) - Monday, 13 April 2015, 19:22 GMT
@guerch

I tried lightdm, but with no luck. Visible message: "Failed to start session"
The lightdm log file says something like: "Failed to find session configuration gnome-wayland"
The lightdm greeter log file gives me a GLib-CRITICAL error message, similar to some reported above.

'startx' did not work either. It just kicks me back to the terminal.

EDIT: My mistake! I neglected to put "exec gnome-session" in .xinitrc. startx works for me now! Thanks!
Comment by Guilherme Gonçcalves (guerch) - Monday, 13 April 2015, 20:48 GMT
glad i could help Michiel, your case sure is smelling of a bug in GDM (perhaps the new wayland shenens), our case it seems goes a little deeper.
Comment by Michael Borden (taksuyu) - Monday, 13 April 2015, 21:11 GMT
I'm having the problem with AMD using the open source drivers, two monitors, launched with gdm, using lts kernel, on btrfs.

I attached a dumped journal log, hopefully it helps.
Comment by richard parris (arpee) - Tuesday, 14 April 2015, 10:14 GMT
I have exactly the same problem.

I have isolated it to my Logitec USB headset. If I unplug the headset I can start the shell (and not have gnome-settings-daemon segfault) without issues. I can reproduce by plugging the headset in after boot and killing and restarting the daemon.

Apr 14 16:55:23 lu gnome-session[516]: (gnome-settings-daemon:534): GLib-CRITICAL **: g_variant_new_string: assertion 'string != NULL' failed
Apr 14 16:55:23 lu gnome-session[516]: (gnome-settings-daemon:534): GLib-CRITICAL **: g_variant_ref_sink: assertion 'value != NULL' failed
Apr 14 16:55:23 lu gnome-session[516]: (gnome-settings-daemon:534): GLib-CRITICAL **: g_variant_new_string: assertion 'string != NULL' failed
Apr 14 16:55:23 lu gnome-session[516]: (gnome-settings-daemon:534): GLib-CRITICAL **: g_variant_ref_sink: assertion 'value != NULL' failed
Apr 14 16:55:23 lu gnome-session[516]: (gnome-settings-daemon:534): GLib-CRITICAL **: g_variant_new_string: assertion 'string != NULL' failed
Apr 14 16:55:23 lu gnome-session[516]: (gnome-settings-daemon:534): GLib-CRITICAL **: g_variant_ref_sink: assertion 'value != NULL' failed
Apr 14 16:55:23 lu kernel: show_signal_msg: 76 callbacks suppressed
Apr 14 16:55:23 lu kernel: gnome-settings-[534]: segfault at 20 ip 00007ff4dd29ff78 sp 00007ffc131ebbd0 error 6 in libglib-2.0.so.0.4400.0[7ff4dd280000+10c000]
Apr 14 16:55:23 lu gnome-session[516]: gnome-session[516]: WARNING: Application 'gnome-settings-daemon.desktop' killed by signal 11
Apr 14 16:55:23 lu gnome-session[516]: WARNING: Application 'gnome-settings-daemon.desktop' killed by signal 11
Apr 14 16:55:23 lu systemd-coredump[639]: Process 534 (gnome-settings-) of user 120 dumped core.
Apr 14 16:55:24 lu gnome-session[516]: Unrecoverable failure in required component gnome-settings-daemon.desktop
Apr 14 16:55:24 lu systemd-coredump[649]: Process 640 (gnome-settings-) of user 120 dumped core.
Apr 14 16:55:24 lu kernel: gnome-settings-[640]: segfault at 20 ip 00007f20f5ea0f78 sp 00007ffc65dce420 error 6 in libglib-2.0.so.0.4400.0[7f20f5e81000+10c000]
Apr 14 16:55:24 lu gnome-session[516]: WARNING: App 'gnome-settings-daemon.desktop' respawning too quickly
Apr 14 16:55:24 lu gnome-session[516]: WARNING: Application 'gnome-settings-daemon.desktop' killed by signal 11
Apr 14 16:55:24 lu gnome-session[516]: (gnome-settings-daemon:640): GLib-CRITICAL **: g_variant_new_string: assertion 'string != NULL' failed
Apr 14 16:55:24 lu gnome-session[516]: (gnome-settings-daemon:640): GLib-CRITICAL **: g_variant_ref_sink: assertion 'value != NULL' failed
Apr 14 16:55:24 lu gnome-session[516]: (gnome-settings-daemon:640): GLib-CRITICAL **: g_variant_new_string: assertion 'string != NULL' failed
Apr 14 16:55:24 lu gnome-session[516]: (gnome-settings-daemon:640): GLib-CRITICAL **: g_variant_ref_sink: assertion 'value != NULL' failed
Apr 14 16:55:24 lu gnome-session[516]: (gnome-settings-daemon:640): GLib-CRITICAL **: g_variant_new_string: assertion 'string != NULL' failed
Apr 14 16:55:24 lu gnome-session[516]: (gnome-settings-daemon:640): GLib-CRITICAL **: g_variant_ref_sink: assertion 'value != NULL' failed
Apr 14 16:55:24 lu gnome-session[516]: gnome-session[516]: WARNING: App 'gnome-settings-daemon.desktop' respawning too quickly
Apr 14 16:55:24 lu gnome-session[516]: gnome-session[516]: WARNING: Application 'gnome-settings-daemon.desktop' killed by signal 11
Apr 14 16:55:29 lu gdm-password][652]: pam_unix(gdm-password:session): session opened for user richardp by (uid=0)
Comment by Jason Stapels (jstapels) - Tuesday, 14 April 2015, 11:42 GMT
Ah hah! Good find Richard!

I can confirm that removing my Logitech USB wireless dongle solves the issue.

Thanks!
Comment by Dominik Wild (wilddom) - Tuesday, 14 April 2015, 12:08 GMT
In my case it was the Wacom tablet as mentioned by Lucas.
Comment by Jan de Groot (JGC) - Tuesday, 14 April 2015, 13:06 GMT
Please try gnome-settings-daemon 3.16.1.
Comment by Svein-Erik Larsen (feinom) - Tuesday, 14 April 2015, 13:17 GMT
Just installed gnome-settings-daemon 3.16.1-1, and I'm still seeing this issue.
Comment by Guilherme Gonçcalves (guerch) - Tuesday, 14 April 2015, 14:24 GMT
I have found a fix, gnome needs to boot on a single monitor (preferably your primary), just let it boot once on single monitor configuration (unplug all other monitors), reboot, plug the monitors while on gnome, reboot again, profit. (if installing from scratch, just use a single monitor, after install complete while on gnome plug the monitors, profit)

ps: Darn, will i ever have pace with multimonitor on linux?
Comment by Lucas (tr4ce) - Tuesday, 14 April 2015, 15:22 GMT
Yes can confirm, disconnecting my TV and reboot fixed the issue.

Still can't double click with my Wacom in nautilus (does work when I test it in GNOME settings), but that's a separate issue. Not sure if I should open a new one here or in the GNOME bugzilla.
Comment by Jason Gerecke (jgerecke) - Tuesday, 14 April 2015, 17:34 GMT
Bug + patch (for at least one of the issues people are seeing) filed with GNOME: https://bugzilla.gnome.org/show_bug.cgi?id=747865
Comment by Guilherme Gonçcalves (guerch) - Tuesday, 14 April 2015, 22:33 GMT
That's related to the wacom bug, but this multimonitor bug its going to remain yet another "gotcha" as long as it's not advertised and fixed (As much as i have investigated this i still don't know what to put in the bug report upstream), i am a friend of gnome, but i think they don't make all the tests they should. As for us, might i suggests placing some news telling folks that use multiple monitors on how to install gnome?
Comment by enrico stano (enricostn) - Monday, 20 April 2015, 16:24 GMT
Not sure if related, but today I upgraded some Gnome package to 3.16 and I'm getting the same error.

To be precise, I'm just using gnome-session and gnome-settings-daemon [i3-gnome](https://aur.archlinux.org/packages/i3-gnome/) packages since I use i3 as my window manager.

Here is a gist of my failures from the journal: https://gist.github.com/enricostano/73fa78af75b0d70c731b
Comment by richard parris (arpee) - Tuesday, 21 April 2015, 04:50 GMT
Just installed gnome-settings-daemon 3.16.1-2, and I'm still seeing this issue.
Comment by Guilherme Gonçcalves (guerch) - Tuesday, 21 April 2015, 17:05 GMT
@richard @enrico, you guys try the one monitor fix? (also unplug all peripherals, leave just keyboard + mouse), if you did i think you found a different bug.
Comment by richard parris (arpee) - Wednesday, 22 April 2015, 00:44 GMT
@guerch as above - I do _not_ experience this issue if I remove my logitech usb wireless headset's dongle during shell start. If it is left in - I am continuing to experience this bug as starting gnome-settings-daemon fails.

Richard
Comment by Guilherme Gonçcalves (guerch) - Wednesday, 22 April 2015, 02:15 GMT
Yup, it seems multi-monitors wacoms some dongle's all seem to generate this...
Comment by Christian Bürckert (Kriese) - Wednesday, 22 April 2015, 08:23 GMT
So I tried to remove all monitors & devices without success. I also think this is another bug which might also be related to this
https://bugs.archlinux.org/task/44570
Comment by Guilherme Gonçcalves (guerch) - Friday, 24 April 2015, 02:13 GMT
Now with nvidia 349.16-1, i get the "Oh no! Something has gone wrong", but this time, nothing can be done, super key does nothing, system is inoperable, unplugging etc does nothing, i reverted back to 346, but this is a new issue, one with the nvidia drivers, just posting this here to clarify anyone in the same situation.
Comment by nylan (nylan) - Friday, 24 April 2015, 08:17 GMT
2 different systems with nvidia cards.
I've installed latest updates yesterday at work -> "Oh no! Somesthing has gone wrong"

At home the same result after installing latest updates.

Multimonitor Setup.

Comment by Guilherme Gonçcalves (guerch) - Saturday, 25 April 2015, 17:33 GMT
user benopotamus, found out that if you update your processor microcode (https://bbs.archlinux.org/viewtopic.php?id=195866&p=3) update your microcode -> https://wiki.archlinux.org/index.php/Microcode. This might fix nvidia 349 update. I has worked for me!
Comment by Bruno (Seletotsira) - Sunday, 26 April 2015, 04:05 GMT
i have a nvidia 460 card, just one monitor and the "oh no ..." problem ... login into tty2 and updating the microcode as shown in the link of Guilherme Gonçcalves fixed the problem ... thank you very very much !!!!
Comment by nylan (nylan) - Sunday, 26 April 2015, 09:03 GMT
Updating the microcode solved the issue
Comment by Remon Nashid (remon.nashid) - Sunday, 26 April 2015, 16:08 GMT
Had the same "Oh no" issue, and it's quite independent from any display manager because it even happens when I start X by startx. Tried uninstalling/installing nvidia, gnome, xf86-video-* all to no avail.
Updating the microcode fixed it, though!
Comment by farid (osc) - Sunday, 26 April 2015, 21:30 GMT
updating the microcode didn't fix it for me :( (i had to switch from grub to syslinux since grub had a bug updating the microcode.)

i even reinstalled my system and the problem continues (even with a fresh intall.)

disabling nvidia and using nouveau also causes the computer to freeze all the time do i need to solve this issue with nvidia.

anyother clues on how to fix this, please?

update: i can't get neither gdm nor lightdm to even load.

update 2: some logs
Comment by farid (osc) - Monday, 27 April 2015, 18:16 GMT
...and here is my gdm journal.
Comment by nylan (nylan) - Tuesday, 28 April 2015, 07:03 GMT
@farid
One of my machines worked again without updating microcode.
The bios of this machine was outdated by 2-3 bios versions. After the bios update and resetting to defaults setting the machine at work started without further problems.


Can someone explain the issue?
Comment by Roshan George (roshan) - Friday, 05 June 2015, 02:54 GMT
Just to add on that the solution in https://bugs.archlinux.org/task/44548#comment134753 works for me. I followed the instructions to install the microcode update and it worked.

This is the only thing I did. Nothing else.
Comment by richard parris (arpee) - Friday, 05 June 2015, 03:15 GMT
Ok, I am pretty sure that what I have is an unrelated bug, and needs it's own thread. Can I check here who else is still getting this issue.

I am getting this bug on a machine with AMD CPU and Graphics. It also only happens if I have my logitech wireless headset dongle plugged in.

@farid, @Christian, @guilherme - are we all still getting this bug?

Richard
Comment by farid (osc) - Friday, 05 June 2015, 14:30 GMT
i updated the microcode, reinstalled nvidia and the mkinitcpio -p linux and managed to get in... BUT only if the wacom tablet is not connected. A workaround is to get in and then connect the tablet.
Comment by Roshan George (roshan) - Friday, 05 June 2015, 17:18 GMT
Sorry to butt in, guys, but this may help. I have a Nvidia 970 with the proprietary drivers, an Intel 4770, and a Wacom CTH 480. The only thing I did was the microcode thing. I did not have to unplug anything.
Comment by Tara Devi (Tara) - Friday, 17 July 2015, 10:25 GMT
I had the same problem. I'm running Arch Linux on a Thinkpad T61 with Intel GM965 video. After hours of searching online, making changes and looking at journalctl output, I discovered a couple of postings online that said to try removing xf86-input-libinput. This did the trick and the crashes and dumped cores completely vanished.

I tried to find a more specific cause but was unable to. I can easily reproduce the crash at anytime and it only occurs when gdm or gnome is started with X. gdm on wayland worked just fine for me.

With xf86-input-libinput removed, I learned that X reverts to using evdev and synaptics for my input devices which are just fine though this reduces the number of mouse/trackpad options in the gnome settings panel. I have another laptop that is running gnome just fine with xf86-input-libinput installed.

I am willing to help with finding the specific root cause of these crashes if someone wants me to work with them and try different things for them on my Thinkpad.
Comment by richard parris (arpee) - Monday, 20 July 2015, 01:13 GMT
@tara,

ok - this is fun. I read your post and hoped that we had a solution for this - as it is still an issue for me.

I ran: yaourt -Ss xf86-input-libinput and the output showed this was not installed.

But, I installed it - on the chance that this might cause a more standard error, or provide more information. It has fixed the problem. I can now start/restart gnome shell with my logitech headset dongle plugged in that the shell does not crash.

I will leave this open though - as I still have no idea what the core issue is so can't provide insight.

@devs - let me know if there are any tests/diagnostics you would like.

Richard

Loading...