Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44534 - [gnome-maps] startup crash

Attached to Project: Arch Linux
Opened by John Bug (johnbug) - Friday, 10 April 2015, 14:16 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 11 April 2015, 03:33 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Application crashes on startup after upgrade: [ALPM] upgraded gnome-maps (3.14.2-1 -> 3.16.0-2).

Additional info:
* gnome-maps 3.16.0-2

* (org.gnome.Maps:2189): GLib-GObject-WARNING **: value "0" of type 'gint' is invalid or out of range for property 'window-scaling-factor' of type 'gint'

(org.gnome.Maps:2189): Gdk-ERROR **: The program 'org.gnome.Maps' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
(Details: serial 919 error_code 8 request_code 154 (GLX) minor_code 31)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the GDK_SYNCHRONIZE environment
variable to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)
Trace/breakpoint trap (core dumped)


Steps to reproduce:
Upgrade gnome-maps to version 3.16.0-2.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 11 April 2015, 03:33 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#44531 

Reopen if I'm wrong.
Comment by John Bug (johnbug) - Friday, 10 April 2015, 14:23 GMT
It also crashes with 3.14.2-1.
Comment by Doug Newgard (Scimmia) - Friday, 10 April 2015, 14:46 GMT
Since it happens with the old version, the problem is deeper. I'm pretty sure it's the same as  FS#44531 

Loading...