Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44531 - Totem crashes with nvidia proprietary driver

Attached to Project: Arch Linux
Opened by maho minami (maho) - Friday, 10 April 2015, 11:06 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 01 July 2015, 01:25 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 15
Private No

Details

Description:
Totem crashes with nvidia proprietary driver after gnome 3.16 update.

Additional info:
* Works ok with nouveau
* Tried deleting "~/.config/totem" and "~/.local/share/totem"
* totem 3.16.0-1
gnome-shell 3.16.0-2
nvidia 346.59-1
linux 3.19.3-3
* Coredump: http://a.pomf.se/oeztec.coredump

Steps to reproduce:
Run totem from the menu or terminal with nvidia proprietary driver.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Wednesday, 01 July 2015, 01:25 GMT
Reason for closing:  Fixed
Additional comments about closing:  clutter 1.22.4-1 clutter-gtk 1.6.2-1
Comment by maho minami (maho) - Friday, 10 April 2015, 11:12 GMT
Attached additional files.
Comment by Paul Cox (pauldcox) - Friday, 10 April 2015, 19:03 GMT
Exact same issue and I'm using the nvidia proprietary driver as well.
Comment by Guilherme Rito (guilhermemtr) - Friday, 10 April 2015, 19:07 GMT
I am getting a segmentation fault in libX11.so
Comment by Guilherme Rito (guilhermemtr) - Friday, 10 April 2015, 19:08 GMT
Can you reach gdm? I get stuck in a black screen. however i can run lxde(after setting my xorg.conf to use intel card instead)
Comment by Robert Sprunk (whisprin) - Friday, 10 April 2015, 23:04 GMT
I have the same setup and get the crash as well.
Logging in with GDM works. Having auto-login enabled I don't see GDM during start-up. If I log out of Gnome 3 the boot messages appear instead of GDM login screen.

edit: Also no luck with nvidia driver 349.12 (most recent beta).
Comment by Daniel B. (Bradan) - Saturday, 11 April 2015, 14:38 GMT
I'm also using the nvidia proprietary driver and I get a slightly different log (BadValue instead of BadMatch).

[EDIT]
After restarting the system I get a BadMatch, too.
Comment by Konstantin Y (tm4ig) - Saturday, 11 April 2015, 17:08 GMT
Cheese 3.16.0-1 also crashes with nvidia driver
...The error was 'BadMatch (invalid parameter attributes)'.
(Details: serial 376 error_code 8 request_code 154 (GLX) minor_code 31)...
Comment by Gwendal (gwendal) - Sunday, 12 April 2015, 08:40 GMT
Same issue here with nvidia proprietary drivers and totem:
(totem:2011): Gdk-ERROR **: The program 'totem' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
Comment by Cédric M. Campos (cedricmc) - Sunday, 12 April 2015, 21:27 GMT Comment by Faruk Aydın (hayspat) - Sunday, 12 April 2015, 22:33 GMT
Same issue. Totem, gnome-maps and cheese crashes with nvidia driver. I'm not sure if its related but I also get low fps on gnome-shell animations
Comment by Simone Economo (eKoeS) - Monday, 13 April 2015, 09:44 GMT
Same issues as @hayspat (BadMatch error upon opening Totem, Cheese or Maps with Nvidia proprietary drivers).
Comment by Jonathan Hudson (stronnag) - Monday, 13 April 2015, 18:34 GMT
Pretty much every clutter program crashes with BadMatch on GNOME 3.16 / Nvidia 346.59
Comment by Jan Alexander Steffens (heftig) - Monday, 13 April 2015, 18:40 GMT
Does CLUTTER_BACKEND=x11 help?
Comment by Robert Sprunk (whisprin) - Monday, 13 April 2015, 18:41 GMT
Yes,
CLUTTER_BACKEND=x11 totem
is working!

I can launch totem and play video files.
Comment by Jonathan Hudson (stronnag) - Monday, 13 April 2015, 18:43 GMT
Confirmed working with CLUTTER_BACKEND=x11 on previously crashing clutter applications. Thanks for the workaround.
Comment by Jan de Groot (JGC) - Monday, 13 April 2015, 19:49 GMT
https://bugzilla.gnome.org/show_bug.cgi?id=747489

No need to add more comments here, upstream is already working on a fix.

Loading...