Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44493 - [systemd] Add rescue.target and rescue.service to initramfs

Attached to Project: Arch Linux
Opened by Tobias Hunger (hunger) - Tuesday, 07 April 2015, 19:44 GMT
Last edited by Dave Reisner (falconindy) - Saturday, 18 June 2016, 12:51 GMT
Task Type Feature Request
Category Packages: Core
Status Closed
Assigned To Thomas B├Ąchler (brain0)
Dave Reisner (falconindy)
Tom Gundersen (tomegun)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

Please add rescue.target and rescue.service to the initrd as set up by the systemd hook, in addition to the emergency.target already present.

The emergency target is started right away as the first thing. The rescue.target on the other hand is triggered only after the basic target has been reached. That makes a huge difference with a USB keyboard: The emergency target is reached without any USB drivers loaded, so the keyboard is not functional at that point yet. The rescue.target has everything set up ready to go.

I set severity to high since having a keyboard in the initrd is really helpful when something goes wrong.

Additional info:
* mkinitcpio 18


Steps to reproduce:
Boot with rd.systemd.unit=emergency.target. USB keyboards are not recognized without BIOS support.
This task depends upon

Closed by  Dave Reisner (falconindy)
Saturday, 18 June 2016, 12:51 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#36265 

Loading...