Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44478 - [supertuxkart] Not all assets found - aborting

Attached to Project: Community Packages
Opened by Joël Schaerer (lardon) - Monday, 06 April 2015, 16:55 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Wednesday, 08 April 2015, 10:37 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Supertuxkart fails to start since the latest update

Additional info:
* package version(s) 0.9rc1-2

Steps to reproduce:

[joel@panda .config]$ supertuxkart
[verbose ] main: Error messages and other text output will be logged to /home/joel/.config/supertuxkart/0.8.2/stdout.log.
[info ] [FileManager]: Data files will be fetched from: '../data/'
[info ] [FileManager]: User directory is '/home/joel/.config/supertuxkart/0.8.2/'.
[info ] [FileManager]: Addons files will be stored in '/home/joel/.local/share/supertuxkart/addons/'.
[info ] [FileManager]: Screenshots will be stored in '/home/joel/.cache/supertuxkart/screenshots/'.
[info ] [FileManager]: User-defined grand prix will be stored in '/home/joel/.local/share/supertuxkart/grandprix/'.
[warn ] [FileManager]: Directory 'challenges' not found, aborting.
[warn ] [FileManager]: Directory 'fonts' not found, aborting.
[warn ] [FileManager]: Directory 'gfx' not found, aborting.
[warn ] [FileManager]: Directory 'grandprix' not found, aborting.
[warn ] [FileManager]: Directory 'gui' not found, aborting.
[warn ] [FileManager]: Directory 'library' not found, aborting.
[warn ] [FileManager]: Directory 'models' not found, aborting.
[warn ] [FileManager]: Directory 'music' not found, aborting.
[warn ] [FileManager]: Directory 'tracks' not found, aborting.
[warn ] [FileManager]: Directory 'sfx' not found, aborting.
[warn ] [FileManager]: Directory 'shaders' not found, aborting.
[warn ] [FileManager]: Directory 'skins' not found, aborting.
[warn ] [FileManager]: Directory 'textures' not found, aborting.
[warn ] [FileManager]: Directory 'po' not found, aborting.
[fatal ] [FileManager]: Not all assets found - aborting.
[joel@panda .config]$

This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Wednesday, 08 April 2015, 10:37 GMT
Reason for closing:  Works for me
Additional comments about closing:  Apparently user error as stated in comments.
Comment by Karol Błażewicz (karol) - Monday, 06 April 2015, 18:19 GMT
Works for me on my 32-bit Arch with [testing] repos enabled.
Comment by Joerg (hiker) - Monday, 06 April 2015, 23:58 GMT
You probably happen to have either a /data directory (see the STK bug report https://github.com/supertuxkart/stk-code/issues/2073), or a ../data directory (which does not contain the expected STK data). Can you try to either rename the data directory as a test, and/or start STK from a different directory?
Comment by Joël Schaerer (lardon) - Tuesday, 07 April 2015, 19:11 GMT
Good catch, I have a data folder in my home directory.

Loading...