Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44420 - [xdg-utils] Links opened with chromium from other programms fail / user agent string misinterpreted

Attached to Project: Arch Linux
Opened by Gerry Kessler (renegat) - Tuesday, 31 March 2015, 18:20 GMT
Last edited by Andreas Radke (AndyRTR) - Monday, 09 November 2015, 14:02 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When trying to open a link from an email client programm e.g.

With an instance of chromium already open and the user agent spoofed in the chromium.desktop file like:

Exec=chromium %U --incognito --user-agent='Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/40.0.2214.94 Safari/537.36'

With xdg-utils1.1.0.git20141009-1:

$ xdg-open http://www.google.com

START /usr/bin/chromium "http://www.google.com" --incognito --user-agent='Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/40.0.2214.94 Safari/537.36'
Created new window in existing browser session.

Works!

With xdg-utils 1.1.0.git20150302-1 and also 1.1.0.git20150323-1:

$ xdg-open http://www.google.com

Created new window in existing browser session.

Fails:
It opens the given link in the first tab and opens eight more empty tabs with parts of the user-agent string set in the desktop file.
Seems like the parts of the user agent string are misinterpreted as links to open e.g. 'http://%28windows/'; 'http://nt/'; 'http://x64%29/'; 'http://applewebkit/537.36'; 'http://%28khtml%2C/' ...

Same happens with every application (email client e.g.) when trying to open a link with xdg-utils 1.1.0.git20150302-1 or xdg-utils 1.1.0.git20150323-1 installed.

Downgrading to xdg-utils1.1.0.git20141009-1 solves it.


This task depends upon

Closed by  Andreas Radke (AndyRTR)
Monday, 09 November 2015, 14:02 GMT
Reason for closing:  Upstream
Additional comments about closing:  no response from the op.
Comment by Andreas Radke (AndyRTR) - Tuesday, 31 March 2015, 19:26 GMT
Sounds like a regression. Please report this upstream.

Loading...