Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44382 - [firefox] Segment Fault when visiting some sites

Attached to Project: Arch Linux
Opened by Justin Wong (bigeagle) - Saturday, 28 March 2015, 06:57 GMT
Last edited by Evangelos Foutras (foutrelis) - Tuesday, 31 March 2015, 05:17 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Ionut Biru (wonder)
Evangelos Foutras (foutrelis)
Jan Steffens (heftig)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Firefox always crash with segfault when visiting https://passport.jd.com/new/login.aspx , core dump shows segfault is from libpthread.so


Additional info:
* package version(s): 36.0.4-1
* config and/or log files etc.


Steps to reproduce:

* open https://passport.jd.com/new/login.aspx with firefox
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Tuesday, 31 March 2015, 05:17 GMT
Reason for closing:  Works for me
Additional comments about closing:  Possible conflict with profile-sync-daemon which is unsupported software.
Comment by Doug Newgard (Scimmia) - Saturday, 28 March 2015, 15:18 GMT
I don't get a firefox crash, but going to their site in either Chromium or Firefox is crashing xfce4-panel on my system. WTF?

BTW, wow, that's a horrible page.

Edit: could be a font issue. Last error I get before the panel SIGABRTs is (process:865): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
xfce4-panel: cairo-scaled-font.c:459: _cairo_scaled_glyph_page_destroy: Assertion `!scaled_font->cache_frozen' failed.
Comment by Doug Newgard (Scimmia) - Monday, 30 March 2015, 04:00 GMT
This should cover everyone in the stack: <browser> -> gtk2 -> cairo
Comment by Evangelos Foutras (foutrelis) - Monday, 30 March 2015, 05:43 GMT
According to the following forum thread, installing ttf-droid and/or ttf-dejavu solves the crashes:

https://bbs.archlinux.org/viewtopic.php?id=169075

I also found an upstream report for xfce4-panel: https://bugzilla.xfce.org/show_bug.cgi?id=10616
Comment by Justin Wong (bigeagle) - Monday, 30 March 2015, 05:56 GMT
hmmm, I've already installed ttf-droid and ttf-dejavu. Font should not be the substaintial part of this issue.
Comment by Justin Wong (bigeagle) - Monday, 30 March 2015, 11:20 GMT
Interesting, this bug does not appear on my laptop.
Comment by Doug Newgard (Scimmia) - Monday, 30 March 2015, 14:59 GMT
I already had ttf-dejavu installed, installing ttf-droid does keep xfce4-panel from crashing.

I still can't reproduce the original issue.
Comment by Justin Wong (bigeagle) - Tuesday, 31 March 2015, 05:04 GMT
After stopping profile-sync-daemon, this bug would not show. I guess I've found the cause.
Comment by Evangelos Foutras (foutrelis) - Tuesday, 31 March 2015, 05:16 GMT
Thanks for the update. I'll go ahead and close this then.

Loading...