Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44380 - [ca-certificates-mozilla] 3.18.2 broke youtube-dl

Attached to Project: Arch Linux
Opened by c (c) - Friday, 27 March 2015, 22:25 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 28 March 2015, 00:29 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Today's update to ca-certificates-mozilla-3.18.2 broke youtube-dl:

ERROR: Unable to download webpage: <urlopen error [SSL:CERTIFICATE_VERIFY_FAILED]
certificate verify failed (_ssl.c:581)> (caused by
URLError(SSLError(1, u'[SSL:CERTIFICATE_VERIFY_FAILED] certificate
verify failed (_ssl.c:581)'),))

Downgrading to ca-certificates-mozilla-3.17.4-1 fixed it.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 28 March 2015, 00:29 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#44378 
Comment by c (c) - Friday, 27 March 2015, 23:50 GMT
Is it possible this happened because ca-certificates-mozilla was updated to 3.18.2 but the ca-certificates-20140923-10 and ca-certificates-utils-20140923-10 updates weren't instealled by pacman for some reason? I've now re-updated ca-certificates-mozilla to 3.18.2 and youtube-dl seems to work. Could this have been the reason and if that's the case is there a way to prevent this in the future?

Loading...