Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44378 - [ca-certificates-mozilla] google.com's SSL certificate is no longer trusted in 3.18

Attached to Project: Arch Linux
Opened by Thomas Hebb (tchebb) - Friday, 27 March 2015, 18:45 GMT
Last edited by Jan Alexander Steffens (heftig) - Saturday, 28 March 2015, 01:30 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan de Groot (JGC)
Pierre Schmitz (Pierre)
Ionut Biru (wonder)
Jan Alexander Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: When attempting to access a site signed using the Google Internet Authority G2 certificate (and possibly others), curl throws an "unable to get local issuer certificate" error. The problem was introduced in ca-certificates-mozilla 3.18; it is not present in 3.17.4.

Steps to reproduce:
1. Upgrade to ca-certificates-mozilla 3.18-1 from [testing]
2. Run "curl -L https://google.com/";
3. Observe SSL error

Expected result: site is fetched without error
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Saturday, 28 March 2015, 01:30 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.18-2

Loading...