Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44374 - [pacman-mirrorlist] 404 for package from mirror.umd.edu

Attached to Project: Arch Linux
Opened by Mark E. Lee (bluerider) - Friday, 27 March 2015, 15:30 GMT
Last edited by Florian Pritz (bluewind) - Friday, 10 July 2015, 15:42 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Florian Pritz (bluewind)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

When running pacman -S avahi using mirror.umd.edu in the mirrorlist, I get a 404 error. I'm writing this bug in after an IRC discussion with Florian.
This task depends upon

Closed by  Florian Pritz (bluewind)
Friday, 10 July 2015, 15:42 GMT
Reason for closing:  Fixed
Comment by Mark E. Lee (bluerider) - Friday, 27 March 2015, 15:35 GMT
As discussed on the IRC channel, since mirrors don't generate their own *.db but just rsync those files, it's possible that if the rsync process is interrupted, *.db files can be updated but listed packages may not exist. I recommended the adding of an until loop to Florian's syncrepo.sh (I have attached the changed lines)
Comment by Doug Newgard (Scimmia) - Friday, 27 March 2015, 16:01 GMT
He told you to file a bug report here?
Comment by Florian Pritz (bluewind) - Friday, 27 March 2015, 16:15 GMT
Yeah, I did.
Comment by Doug Newgard (Scimmia) - Friday, 27 March 2015, 16:23 GMT
ok, then for future reference, why? What can be done here?
Comment by Florian Pritz (bluewind) - Friday, 27 March 2015, 16:31 GMT
I believe those issue to be caused by mirrors not using --delay-updates and I'd like to know which mirrors have issues so I can ask the admins. If it turns out my hunch is correct that will be all, otherwise I'll try to get people to use a more robust mirror script.
Comment by Mark E. Lee (bluerider) - Friday, 27 March 2015, 20:50 GMT
There are two options off the top of my head:
1) Standardize the way mirrors are synced (a more formal method of Florian is talking about)
2) Standardize how low level tiers are rsynced via /etc/rsyncd.conf (try to configure the rsync daemon to refuse mirrors not using --delay-updates, etc.)
Comment by Mark E. Lee (bluerider) - Monday, 06 April 2015, 16:04 GMT
I've been encountering 404 errors from mirror.umd.edu for three days now. Is there any progress on this bug?
Comment by Florian Pritz (bluewind) - Tuesday, 07 April 2015, 18:58 GMT
Still waiting on a reply, but it's easter right now and at least my university has 2 weeks of holidays (last and this week) so I'm cutting them some slack. Maybe you should consider using a different mirror until this is resolved if you run into the issue that often.
Comment by Moshe Katz (kohenkatz) - Friday, 01 May 2015, 15:36 GMT
I'm one of the maintainers of that mirror.

In the last week of March and the first two weeks of April, we had some hardware issues with a disk controller that were causes inability to access certain files.
Before that, during January and February we were having problems with 404 errors from our upstream which was polymorf.fr (we changed upstreams in the first week of February to use Leaseweb and we haven't seen those errors again) but I don't think that this is an issue anymore.

Comment by Florian Pritz (bluewind) - Friday, 01 May 2015, 15:47 GMT
I've just sent a mail to leaseweb to help clarify the situation. I'll post again when I've narrowed down the problem.
Comment by Florian Pritz (bluewind) - Friday, 10 July 2015, 15:42 GMT
Finally managed to get a reply from leaseweb. They've adapted their rsync options so this should be fixed now. If it happens again please reopen this bug report.

Loading...