Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44329 - [thunar] requires perl-uri for sending a file by email

Attached to Project: Arch Linux
Opened by Bruno (bruno_hennezel) - Tuesday, 24 March 2015, 20:48 GMT
Last edited by Evangelos Foutras (foutrelis) - Thursday, 26 March 2015, 07:54 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Sending file by email from Thunar requires perl URI/Escape.pm.
Without perl-uri, a window pops-up saying
Ā«Failed to execute default Mail Reader
Input/output errorĀ»
Thunar uses this perl script :
/usr/lib/xfce4/exo-1/exo-compose-mail-1
The latter file is own by exo ... but used by Thunar.

Additional info:
* package version(s)
extra/thunar 1.6.6-1 (xfce4)
extra/exo 0.10.4-2 (xfce4)

* config and/or log files etc.


Steps to reproduce:
Right clic on a file from Thunar and try to send it by email, without perl-uri installed.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Thursday, 26 March 2015, 07:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  perl-uri dependency made non-optional in exo 0.10.4-3.
Comment by Evangelos Foutras (foutrelis) - Wednesday, 25 March 2015, 11:25 GMT
The exo package has an optional dependency on perl-uri:

perl-uri: for mail-compose helper script

I might make it a hard dependency though, since the error message isn't very helpful and nearly all systems have perl anyway and perl-uri is tiny.
Comment by Bruno (bruno_hennezel) - Thursday, 26 March 2015, 07:26 GMT
Oh, I'm sorry, I haven't seen the dependency suggested in exo.

I think a hard dependency could be better if all systems have perl.

Thank you.

Loading...