Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44315 - [linux] ALX driver does not work correctly in 3.19.2 kernel

Attached to Project: Arch Linux
Opened by Ongun Kanat (6ng4n) - Tuesday, 24 March 2015, 01:01 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 10 August 2016, 22:37 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No

Details

Description:
Last day I've upgraded my kernel which is 3.18.6 to 3.19.2. Since the upgrade my ethernet connection is not working properly. I've an AR8161 card so my driver is ALX. I've looked at dmesg, also recompiled kernel from ABS with debuging on.

The behaviour is strange. It sometimes connects, sometimes not(I use DHCP, NetworkManager with dhclient also tried with wicd). In both cases I cannot connect any host(ping etc.) neither by IP nor by domain name. I cannot use any of my browsers. Most of the time It does not print anything to dmesg. However rarely when I do some network operations the message below is printed to dmesg.

alx 0000:04:00.0 eth0: fatal interrupt 0x400, resetting

Additional info:
linux-3.19.2-1

My PC is a ASUS N56VZ
Core i7 3610QM Processor with 8G RAM
Atheros AR8161 ethernet

Steps to reproduce:
Upgrade kernel to 3.19.2.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Wednesday, 10 August 2016, 22:37 GMT
Reason for closing:  Fixed
Comment by Bernhard Rausch (harti) - Tuesday, 24 March 2015, 08:37 GMT
Had the same problem today - I've also upgraded my kernel yesterday from 3.18.6 to 3.19.2.
That was the last thing i did yesterday.

After starting my Lenovo Y580 today I had problems connecting to the network via my "Qualcomm Atheros AR8161 Gigabit Ethernet" -> drivers loaded from dmesg "Qualcomm Atheros AR816x/AR817x Ethernet".
Only short connections where possible. After some seconds the connection was "down". I use a fixed IP here managed by NetworkManager, no DHCP.
First I had IP conflicts in mind because of the strange behaviour but after trying some other IP addresses (with the same problem) I started to look online - and found this thread.

Solution for now:
A downgrade to the old kernel brought me back online...

Additional info:
also linux-3.19.2-1-x86_64

My Laptop:
Lenovo Ideapad Y580 Notebook,
Core i7-3630QM with 8GB RAM
Qualcomm Atheros AR8161 Gigabit Ethernet

Steps to reproduce:
Upgrade kernel to 3.19.2
Comment by Leandro Monteiro dal Bò (leandro) - Thursday, 26 March 2015, 21:17 GMT
+1
Needed to downgrade to 3.18.6-1
Comment by Marco B. (DaMaxx) - Saturday, 04 April 2015, 23:26 GMT
I can confirm this with my Lenovo Y580 as well.

Solution for me was to downgrade to linux-3.18.6-1
Comment by D (.Spharx) - Sunday, 26 April 2015, 13:13 GMT
I also can confirm the same problem on my Y580.
Comment by Ongun Kanat (6ng4n) - Sunday, 26 April 2015, 13:21 GMT
After a short research I've found this:
https://bugzilla.kernel.org/show_bug.cgi?id=70761

I think ALX is very very badly written driver. Shame on you Qualcomm. There is a quick fix that works for me to increase MTU value.

It can be increased with command below:
# ifconfig eth0 mtu 9000

or there is an option in NetworkManager settings for a specific connection. It also solves the connection drops occurring when wifi is on.
If it also solves your problem, I want you guys to upvote the upstream bug.
Comment by D (.Spharx) - Sunday, 26 April 2015, 14:36 GMT
Ongun Kanat: For now this seems to work, thanks! I was just about to downgrade the kernel on several machines.
Comment by Marco B. (DaMaxx) - Monday, 27 April 2015, 05:39 GMT
Works for me as well...
Comment by Bernhard Rausch (harti) - Tuesday, 28 April 2015, 09:04 GMT
Ongun Kanat: many thx for your further investigation - works for me as well!
Comment by Odobesku Vladislav (yang) - Thursday, 14 May 2015, 14:48 GMT
Same here, mtu 8000 works but i'm waiting for better solutions
Comment by dbt (dbt0210) - Monday, 12 October 2015, 21:14 GMT
I can confirm this issue, using the Lenovo Y580. (linux 4.2.2-1)
Increasing the MTU fixes the problem, but I'd rather have this done properly.
Comment by Samantha McVey (samcv) - Friday, 10 June 2016, 22:27 GMT
Hello,
Can anyone confirm whether this is still occurring in the most recent Arch Linux kernels with an MTU of 1500? Thanks, your response is greatly appreciated.
Comment by Samantha McVey (samcv) - Monday, 08 August 2016, 13:57 GMT
Sending out another response. Hopefully one of you can let me know if this problem is still occurring now? Thank you.
Comment by Ongun Kanat (6ng4n) - Monday, 08 August 2016, 14:36 GMT
Ah didn't see the previous one. At the moment I'm not using ethernet but I'll inform you when I'm able to test it.
Regards
Comment by dbt (dbt0210) - Wednesday, 10 August 2016, 14:53 GMT
Finally got the chance to test this. No issues with an MTU of 1500 on linux 4.6.4-1 anymore, the bug seems to be resolved.

Loading...