Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44245 - [qemu] "qemu-system-x86_64: symbol lookup error: qemu-system-x86_64: undefined symbol: libssh2_sftp"

Attached to Project: Arch Linux
Opened by Javier (jevv) - Wednesday, 18 March 2015, 20:34 GMT
Last edited by Tobias Powalowski (tpowa) - Thursday, 19 March 2015, 07:18 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

Keeping packages up to date daily. However after recent update, qemu broke, giving me the following error:

qemu-system-x86_64: symbol lookup error: qemu-system-x86_64: undefined symbol: libssh2_sftp_fsync

If I do updates, I don't get anything new...

My command line:

qemu-system-x86_64 -enable-kvm -name win-8-coe -machine type=pc,accel=kvm -drive file=/home/<username>/.qemu/imgs/win8-coe.qcow2,index=0,media=disk,if=virtio -net nic,model=virtio -net user -usbdevice tablet -usb -m 2.7G -smp cores=1,threads=2,sockets=1 -display sdl -vga std -soundhw ac97 -rtc base=localtime -usbdevice host:0b0e:0032

This same command line was working before today's update. To me qemu is critical, given it's the only way I have for office lync meetings with audio and shared desktops...

Additional info:
* package version(s)
qemu 2.2.1-1

* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Thursday, 19 March 2015, 07:18 GMT
Reason for closing:  Fixed
Additional comments about closing:  qemu-2.2.1-2
qemu-2.2.1-3
Comment by Javier (jevv) - Wednesday, 18 March 2015, 20:49 GMT
Note that reverting to 2.2.0-2 made qemu work as before, which probably was expected, :-)
Comment by Justin Vreeland (jvreeland) - Wednesday, 18 March 2015, 21:32 GMT
Same problem here.
Comment by Fabien Bourigault (fbourigault) - Wednesday, 18 March 2015, 22:21 GMT
qemu 2.2.1-1 depends on libssh2 1.5.0-1 from testing.
Comment by Dave Reisner (falconindy) - Wednesday, 18 March 2015, 23:18 GMT
So, there's 2 problems here:

1) qemu as a package needs to depend on libssh2 since /usr/bin/qemu-systemd-x86_64 links directly to libssh2.so. I don't care that curl uses libssh2, if you link directly to a lib, you should absolutely depend on it.
2) qemu-2.2.1-1 was likely built in a dirty root, or else the configure script wouldn't have detected the available libssh2 as having this particular symbol.
Comment by Tobias Powalowski (tpowa) - Thursday, 19 March 2015, 07:15 GMT
Sorry build it against testing.

Loading...