Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44145 - [firefox] URLs in other programs open new empty window (fix included in upstream bug report)

Attached to Project: Arch Linux
Opened by Michael Kogan (Photon) - Wednesday, 11 March 2015, 11:18 GMT
Last edited by Evangelos Foutras (foutrelis) - Wednesday, 11 March 2015, 13:34 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details


Steps to reproduce:

Set Firefox as standard browser. Run "xdg-open www.some-url.de". A new empty Firefox window opens.

The bug has been reported upstream: https://bugzilla.mozilla.org/show_bug.cgi?id=1138161 It is not a bug in Firefox but a compatibility loss in the new Firefox versions. The firefox.desktop files need to be edited by removing the "-remote" option to avoid the problem. Further details in the upstream bug report.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Wednesday, 11 March 2015, 13:34 GMT
Reason for closing:  Not a bug
Comment by Evangelos Foutras (foutrelis) - Wednesday, 11 March 2015, 12:07 GMT
I fixed this (in Xfce) two weeks ago:

https://projects.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/exo&id=a3391f1

Furthermore, Firefox 36.0.1 has restored the -remote switch.
Comment by Michael Kogan (Photon) - Wednesday, 11 March 2015, 13:10 GMT
Thanks for the quick reply, then I'm just waiting for 36.0.1!
Comment by Evangelos Foutras (foutrelis) - Wednesday, 11 March 2015, 13:34 GMT
No need to wait, since the Firefox 36.0.1 update was pushed to [extra] 5 days ago.

Please note that if you're using a downstream distro, you'd need to report issues on their bug tracker and not Arch's.

Loading...