Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44113 - [xfce4-settings] doesn't remember keyboard locale on access

Attached to Project: Arch Linux
Opened by Nesser (Decepteiskon) - Monday, 09 March 2015, 13:31 GMT
Last edited by Evangelos Foutras (foutrelis) - Saturday, 03 October 2015, 22:08 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Architecture i686
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: after the update to XFCE 4.12 the keyboard locale defaults to US, even if the keymap in Settings/Keyboard is the right one, checking "Use system settings" does nothing in the current session (it says to logout and retry, nothing helps), the only workaround is adding another keymap, moving it to the top, move the original to the top and remove the added keymap.


Additional info:
* package version(s)
Xfce 4.12

* config and/or log files etc.

$ localectl status
System Locale: LANG=it_IT.UTF-8
VC Keymap: it
X11 Layout: it
X11 Model: pc105
X11 Options: terminate:ctrl_alt_bksp


Steps to reproduce: nothing, the problem is right after the login.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Saturday, 03 October 2015, 22:08 GMT
Reason for closing:  Won't fix
Additional comments about closing:  See last comment.
Comment by Nesser (Decepteiskon) - Thursday, 12 March 2015, 12:52 GMT
Gone right after xfce4-xkb-plugin (0.5.6-2 -> 0.7.1-2), today same behavior from before. Weird.
Comment by Nesser (Decepteiskon) - Tuesday, 17 March 2015, 13:02 GMT
Looks pretty random, sometimes uses the right layout and some not, workaround is still to have 2 layout switchable with panel applet.
Btw, i have 2 keyboards, the one on the laptop and the one that i'm using now, external. Could be a problem with multiple keyboards.
Comment by Nesser (Decepteiskon) - Tuesday, 24 March 2015, 18:03 GMT Comment by Evangelos Foutras (foutrelis) - Tuesday, 24 March 2015, 18:20 GMT
Does it at least work fine when xfce4-xkb-plugin is used? Or if you disconnect the external keyboard?

I've tested with a single layout defined in xfce4-keyboard-settings and it was correctly selected upon starting Xfce.
Comment by Nesser (Decepteiskon) - Wednesday, 25 March 2015, 22:23 GMT
Always work right with the panel applet, w/o works randomly. I have that Logitech dongle.
Comment by Evangelos Foutras (foutrelis) - Thursday, 26 March 2015, 08:21 GMT
If it only happens with the external keyboard, then it's not something I can investigate.

Can you please confirm if this is the case?
Comment by Nesser (Decepteiskon) - Thursday, 26 March 2015, 15:26 GMT
I boot with the external keyboard (dongle) connected, so that's what is happened now: after the login (keyboard plugin in the panel not enabled, not using it) i got the wrong layout (english) i opened a terminal to test the keyboard, typing - got me / , the wrong layout behavior. I disconnected the dongle and typed again - from the laptop keyboard, it wrote - instead of the / , so it was the right layout. I haven't changed anything, just removed the dongle from the usb port and typed with the internal keyboard.

So using the panel plugin sets the right layout, and even disconnecting the dongle sets the right layout if the wrong one is used. Very weird. Seems related to that Unifying voice in the Arch wiki. Maybe the driver for the dongle sets US layout somewhere in it, conflicting with the Xfce behavior.
Comment by vincent (humhumhum) - Saturday, 11 April 2015, 22:47 GMT
I have pretty much the same bug still the update to xfce4 4.12:

xfce4-keyboard-settings do the right thing as long as if I don't define an us keyborad in the layout list.
For example for a /Default/XkbLayout = fr,dk,de the default layout is fr

But as soon as I add an us keyboard whatever his position, the us keyboard is selected by default.
For example for a /Default/XkbLayout = fr,dk,us,de the default layout is us and not fr.
To be exhaustive my keyboard outside X is the default keyboard ie the us one.

localectl status returns
System Locale: LANG=en_GB.UTF-8
VC Keymap: us
X11 Layout: us
X11 Model: pc104
X11 Variant: altgr-intl

if I use/install the xfce4-xkb-plugin with the option <<Manage layout>> per-window or per-application the default layout is fr.
But with the <<Manage layout>> globally even with a fr layout text/image displayed, I have an us layout by default.

Comment by Nesser (Decepteiskon) - Tuesday, 14 April 2015, 01:50 GMT
Do you have a Logitech Unifying device with paired keyboard/mouse set?
Comment by Evangelos Foutras (foutrelis) - Saturday, 03 October 2015, 22:08 GMT
@vincent: I'm going to assume that behavior is normal; xfce4-settings sets the available layouts (through libxklavier) but that doesn't necessarily mean it will switch to the first one. During my testing when this task was originally filed, it appears that the active layout is maintained from before X is launched.

Closing this at the request of Nesser since the issue appears to affect Unifying devices only and doesn't seem to be triggered by xfce4-settings itself.

Loading...