Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44089 - [xf86-video-intel] Xorg crashes when trying to scroll in Arduino IDE

Attached to Project: Arch Linux
Opened by Tomi Leppänen (Tomin) - Saturday, 07 March 2015, 17:51 GMT
Last edited by Laurent Carlier (lordheavy) - Sunday, 21 June 2015, 11:58 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
In Arduino IDEon the right side of the file tabs there is a button that shows list of open files. If I try to scroll that list Xorg crashes always and brings me back to gdm login screen. Backtrace:
maalis 07 19:07:57 tomin-xps gdm-Xorg-:0[450]: (EE)
maalis 07 19:07:57 tomin-xps gdm-Xorg-:0[450]: (EE) Backtrace:
maalis 07 19:07:57 tomin-xps gdm-Xorg-:0[450]: (EE) 0: /usr/lib/xorg-server/Xorg (OsLookupColor+0x119) [0x5949c9]
maalis 07 19:07:57 tomin-xps gdm-Xorg-:0[450]: (EE) 1: /usr/lib/libc.so.6 (__restore_rt+0x0) [0x7fd06034253f]
maalis 07 19:07:57 tomin-xps gdm-Xorg-:0[450]: (EE) 2: /usr/lib/xorg/modules/drivers/intel_drv.so (_init+0x35f14) [0x7fd05af4fbc4]
maalis 07 19:07:57 tomin-xps gdm-Xorg-:0[450]: (EE) 3: /usr/lib/xorg/modules/drivers/intel_drv.so (_init+0x3ed4c) [0x7fd05af6159c]
maalis 07 19:07:57 tomin-xps gdm-Xorg-:0[450]: (EE) 4: /usr/lib/xorg-server/Xorg (DamageRegionAppend+0x29f6) [0x51e326]
maalis 07 19:07:57 tomin-xps gdm-Xorg-:0[450]: (EE) 5: /usr/lib/xorg-server/Xorg (SendGraphicsExpose+0x72f) [0x4354af]
maalis 07 19:07:57 tomin-xps gdm-Xorg-:0[450]: (EE) 6: /usr/lib/xorg-server/Xorg (SendErrorToClient+0x2f7) [0x438a97]
maalis 07 19:07:57 tomin-xps gdm-Xorg-:0[450]: (EE) 7: /usr/lib/xorg-server/Xorg (remove_fs_handlers+0x41b) [0x43cbcb]
maalis 07 19:07:57 tomin-xps gdm-Xorg-:0[450]: (EE) 8: /usr/lib/libc.so.6 (__libc_start_main+0xf0) [0x7fd06032f800]
maalis 07 19:07:57 tomin-xps gdm-Xorg-:0[450]: (EE) 9: /usr/lib/xorg-server/Xorg (_start+0x29) [0x427039]
maalis 07 19:07:57 tomin-xps gdm-Xorg-:0[450]: (EE) 10: ? (?+0x29) [0x29]
maalis 07 19:07:57 tomin-xps gdm-Xorg-:0[450]: (EE)
maalis 07 19:07:57 tomin-xps gdm-Xorg-:0[450]: (EE) Segmentation fault at address 0x7fff7ac8d4ac
maalis 07 19:07:57 tomin-xps gdm-Xorg-:0[450]: (EE)
maalis 07 19:07:57 tomin-xps gdm-Xorg-:0[450]: Fatal server error:
maalis 07 19:07:57 tomin-xps gdm-Xorg-:0[450]: (EE) Caught signal 11 (Segmentation fault). Server aborting
maalis 07 19:07:57 tomin-xps gdm-Xorg-:0[450]: (EE)
maalis 07 19:07:57 tomin-xps gdm-Xorg-:0[450]: (EE)
maalis 07 19:07:57 tomin-xps gdm-Xorg-:0[450]: Please consult the The X.Org Foundation support
maalis 07 19:07:57 tomin-xps gdm-Xorg-:0[450]: at http://wiki.x.org
maalis 07 19:07:57 tomin-xps gdm-Xorg-:0[450]: for help.
maalis 07 19:07:57 tomin-xps gdm-Xorg-:0[450]: (EE) Please also check the log file at "/dev/null" for additional information.

Seems to be Intel related and probably won't happen on other hardware but you could try anyway. I'm using SNA acceleration as it is the default on Arch Linux nowadays.

Additional info:
* package version(s)
extra/xorg-server 1.17.1-3
extra/xorg-server-common 1.17.1-3
extra/xf86-video-intel 2.99.917-3
extra/gnome-shell 3.14.3-2
extra/gdm 3.14.1-2
extra/libgdm 3.14.1-2
local/arduino 1:1.6.0-1 ( https://aur.archlinux.org/packages/arduino/ )
* config and/or log files etc.
Dell XPS13 (9333) laptop with Intel Haswell graphics (HD4400, SNA) and Arch Linux (x86_64). I don't have anything else to test this with right now.
journalclt --system --since=2015-03-07 as an attachment (xorg_crash-2015-03-07.log). There is probably a lot of not that useful information and you might want to grep gdm-Xorg. The exiting stuff starts at 19:07:57 where there is the backtrace. The log does not include the information when Xorg was started because that was days ago but there is the log after the crash and even after that I crashed the Xorg again the very same way. If you need more logs, just ask. If I should report this to upstream, please tell me to do so.

Steps to reproduce:
1. Install Arduino IDE (1.6) from AUR.
2. Open some project with a lot of files (I used Marlin firmware: https://github.com/MarlinFirmware/Marlin/releases )
3. Click on the arrow next to the file tabs.
4. Try to scroll the list.
Xorg should crash.
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Sunday, 21 June 2015, 11:58 GMT
Reason for closing:  Fixed
Comment by Tomi Leppänen (Tomin) - Saturday, 07 March 2015, 17:51 GMT
Right, forgot something...
core/linux 3.18.6-1
Comment by Tomi Leppänen (Tomin) - Saturday, 07 March 2015, 18:05 GMT
Upgraded some packages still crashing:
local/xorg-server 1.17.1-3 (xorg)
local/xorg-server-common 1.17.1-3
local/xorg-server-devel 1.17.1-3
local/linux 3.19-1 (base)
local/xf86-video-intel 2.99.917-3 (xorg-drivers xorg)
local/mesa 10.4.6-1
local/gnome-shell 3.14.3-2 (gnome)
local/gdm 3.14.1-2 (gnome)
local/libgdm 3.14.1-2
local/arduino 1:1.6.0-1
https://pastebin.com/bMPMrRpz
Comment by Andreas Radke (AndyRTR) - Saturday, 20 June 2015, 12:57 GMT
Has this been fixed with recent kernels/Xorg/intel driver?
Comment by Tomi Leppänen (Tomin) - Sunday, 21 June 2015, 08:42 GMT
I can't reproduce this anymore. I'm running xorg-server 1.17.2-1, Linux 4.1-rc7, xf86-video-intel 2.99.917-5, mesa 10.5.7-1, gnome-shell 3.16.2-2, gdm 3.16.1.1-3 and Arduino 1.6.5-1.

Loading...