Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44068 - xfce libxfce4util.so.6 missing

Attached to Project: Arch Linux
Opened by Georg (georgnix) - Friday, 06 March 2015, 12:28 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 06 March 2015, 14:25 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Just tried upgrading to xfce from testing using

pacman -S $(pacman -Qq | grep xfce)

[2015-03-06 13:03] [PACMAN] Running 'pacman -S xfce4-appfinder xfce4-artwork xfce4-battery-plugin xfce4-clipman-plugin xfce4-cpufreq-plugin xfce4-cpugraph-plugin xfce4-datetime-plugin xfce4
-dev-tools xfce4-dict xfce4-diskperf-plugin xfce4-eyes-plugin xfce4-fsguard-plugin xfce4-genmon-plugin xfce4-mailwatch-plugin xfce4-mixer xfce4-mount-plugin xfce4-mpc-plugin xfce4-netload-p
lugin xfce4-notes-plugin xfce4-notifyd xfce4-panel xfce4-power-manager xfce4-quicklauncher-plugin xfce4-screenshooter xfce4-sensors-plugin xfce4-session xfce4-settings xfce4-smartbookmark-p
lugin xfce4-systemload-plugin xfce4-taskmanager xfce4-terminal xfce4-time-out-plugin xfce4-timer-plugin xfce4-verve-plugin xfce4-wavelan-plugin xfce4-weather-plugin xfce4-xkb-plugin'
[2015-03-06 13:03] [PACMAN] Running 'pacman -S gtk2-xfce-engine gtk3-xfce-engine libxfce4ui libxfce4util libxfcegui4 xfce4-appfinder xfce4-artwork xfce4-battery-plugin xfce4-clipman-plugin
xfce4-cpufreq-plugin xfce4-cpugraph-plugin xfce4-datetime-plugin xfce4-dev-tools xfce4-dict xfce4-diskperf-plugin xfce4-eyes-plugin xfce4-fsguard-plugin xfce4-genmon-plugin xfce4-mailwatch-
plugin xfce4-mixer xfce4-mount-plugin xfce4-mpc-plugin xfce4-netload-plugin xfce4-notes-plugin xfce4-notifyd xfce4-panel xfce4-power-manager xfce4-quicklauncher-plugin xfce4-screenshooter x
fce4-sensors-plugin xfce4-session xfce4-settings xfce4-smartbookmark-plugin xfce4-systemload-plugin xfce4-taskmanager xfce4-terminal xfce4-time-out-plugin xfce4-timer-plugin xfce4-verve-plu
gin xfce4-wavelan-plugin xfce4-weather-plugin xfce4-xkb-plugin'
transaction started
reinstalled gtk2-xfce-engine (3.0.1-2)
reinstalled gtk3-xfce-engine (3.0.1-2)
upgraded libxfce4util (4.10.1-2 -> 4.12.1-1)
upgraded libxfce4ui (4.10.0-2 -> 4.12.0-1)
upgraded libxfcegui4 (4.10.0-2 -> 4.10.0-4)
upgraded xfce4-appfinder (4.10.1-1 -> 4.12.0-1)
reinstalled xfce4-artwork (0.1.1a_git20110420-4)
upgraded xfce4-panel (4.10.1-2 -> 4.12.0-1)
upgraded xfce4-battery-plugin (1.0.5-3 -> 1.0.5-4)
upgraded xfce4-clipman-plugin (1.2.6-1 -> 1.2.6-2)
upgraded xfce4-cpufreq-plugin (1.1.1-1 -> 1.1.1-2)
upgraded xfce4-cpugraph-plugin (1.0.5-2 -> 1.0.5-3)
upgraded xfce4-datetime-plugin (0.6.2-3 -> 0.6.2-4)
upgraded xfce4-dev-tools (4.10.0-2 -> 4.12.0-1)
upgraded xfce4-dict (0.7.0-1 -> 0.7.0-2)
upgraded xfce4-diskperf-plugin (2.5.4-2 -> 2.5.5-1)
upgraded xfce4-eyes-plugin (4.4.3-1 -> 4.4.3-2)
upgraded xfce4-fsguard-plugin (1.0.1-3 -> 1.0.2-4)
upgraded xfce4-genmon-plugin (3.4.0-2 -> 3.4.0-3)
upgraded xfce4-mailwatch-plugin (1.2.0-4 -> 1.2.0-5)
upgraded xfce4-mixer (4.11.0-1 -> 4.11.0-2)
upgraded xfce4-mount-plugin (0.6.7-2 -> 0.6.7-3)
upgraded xfce4-mpc-plugin (0.4.4-3 -> 0.4.5-1)
upgraded xfce4-netload-plugin (1.2.4-1 -> 1.2.4-2)
upgraded xfce4-notes-plugin (1.7.7-6 -> 1.7.7-7)
upgraded xfce4-notifyd (0.2.4-1 -> 0.2.4-2)
upgraded xfce4-power-manager (1.4.2-2 -> 1.4.3-1)
upgraded xfce4-quicklauncher-plugin (1.9.4-9 -> 1.9.4-10)
upgraded xfce4-screenshooter (1.8.2-1 -> 1.8.2-2)
upgraded xfce4-sensors-plugin (1.2.6-1 -> 1.2.6-2)
installed polkit-gnome (0.105-2)
upgraded xfce4-session (4.10.1-5 -> 4.12.0-2)
upgraded xfce4-settings (4.10.1-1 -> 4.12.0-2)
upgraded xfce4-smartbookmark-plugin (0.4.5-2 -> 0.4.5-3)
upgraded xfce4-systemload-plugin (1.1.2-1 -> 1.1.2-2)
reinstalled xfce4-taskmanager (1.1.0-1)
upgraded xfce4-terminal (0.6.3-1 -> 0.6.3-2)
upgraded xfce4-time-out-plugin (1.0.1-4 -> 1.0.1-5)
upgraded xfce4-timer-plugin (1.6.0-1 -> 1.6.0-2)
upgraded xfce4-verve-plugin (1.0.1-1 -> 1.0.1-2)
upgraded xfce4-wavelan-plugin (0.5.11-2 -> 0.5.12-1)
upgraded xfce4-weather-plugin (0.8.5-1 -> 0.8.5-2)
upgraded xfce4-xkb-plugin (0.5.6-1 -> 0.5.6-2)
transaction completed

This is what I get in the journal when logging in via lightdm:

Mar 06 13:06:59 gurke org.xfce.Xfconf[8011]: /usr/lib/xfce4/xfconf/xfconfd: error while loading shared libraries: libxfce4util.so.6:
cannot open shared object file: No such file or director
... (lots of these) ...

Autoruns are apparently executed (see some apps), but no panel, no functional window decorations etc.
Seems like there is something wrong with the dependencies of the xfce packages?

% uname -a
Linux gurke 3.18.6-1-ARCH #1 SMP PREEMPT Sat Feb 7 08:44:05 CET 2015 x86_64 GNU/Linux

Steps to reproduce:

* enable testing repository
* pacman -Sy
* pacman -S $(pacman -Qq | grep xfce)

The resulting pacman.log is attached.

This task depends upon

Closed by  Doug Newgard (Scimmia)
Friday, 06 March 2015, 14:25 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Friday, 06 March 2015, 13:45 GMT
What you've done is an unsupported partial upgrade. Run pacman -Su or pacman -Syu and I'd bet your problem will go away. Never run pacman -Sy unless you really know what you're doing.
Comment by Georg (georgnix) - Friday, 06 March 2015, 13:57 GMT
Guessed so, but shouldn't this still be reflected in the dependencies?
Comment by Doug Newgard (Scimmia) - Friday, 06 March 2015, 14:01 GMT
No. Partial updates are unsupported.
Comment by Georg (georgnix) - Friday, 06 March 2015, 14:04 GMT
Ok, thanks. Just close the bug.
Anything I can do for testing xfce?
Comment by Doug Newgard (Scimmia) - Friday, 06 March 2015, 14:18 GMT
Right now the only way is to enable testing and community-testing and update your entire system.
Comment by Georg (georgnix) - Friday, 06 March 2015, 14:20 GMT
Did that. Thanks.

Loading...