Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44009 - [djview] missing dep on libxkbcommon-x11

Attached to Project: Community Packages
Opened by Amos Onn (amos) - Monday, 02 March 2015, 09:08 GMT
Last edited by Gaetan Bisson (vesath) - Monday, 02 March 2015, 17:04 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Gaetan Bisson (vesath)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
djview does not launch with libxkbcommon-x11 not installed. It spits error message:

djview fatal error: This application failed to start because it could not find or load the Qt platform plugin "xcb".

Available platform plugins are: eglfs, kms, linuxfb, minimal, minimalegl, offscreen, xcb.

Reinstalling the application may fix this problem.
zsh: abort (core dumped) djview4

Additional info:
* djview=4.10-1
* libxkbcommon-x11=0.5.0-1

Steps to reproduce:
Uninstall libxkbcommon-x11 (possible, because it is not a dep of djview. Try loading djview.
This task depends upon

Closed by  Gaetan Bisson (vesath)
Monday, 02 March 2015, 17:04 GMT
Reason for closing:  Fixed
Additional comments about closing:  djview-4.10-2 in [community]
Comment by Amos Onn (amos) - Monday, 02 March 2015, 09:25 GMT
Also applies to libsm, another opt-dep of qt5-base for xcb support.

Loading...