Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#44005 - [lxqt-session] dependency: failed to start, tried lxdm and then startx, fixed by libxkbcommon-x11

Attached to Project: Community Packages
Opened by J W Hickman (jwhickman) - Monday, 02 March 2015, 07:35 GMT
Last edited by Jerome Leclanche (Adys) - Saturday, 25 April 2015, 20:43 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jerome Leclanche (Adys)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
This is an x86_64 system, initially running lxde. Upon installing the lxqt group (0.9.0) and trying to run it via lxdm (0.5.0) and later manually via startx, it failed. Installing libxkbcommon-x11 (0.5.0-1) fixed my issue, so it appears the dependencies need updated.

Error messages from journalctl:
/--
This application failed to start because it could not find or load the Qt platform plugin "xcb".
Available platform plugins are: eglfs, kms, linuxfb, minimal, minimalegl, offscreen, xcb.
--/

Steps to reproduce:
See description. Installing libxkbcommon-x11 fixed my issue.
This task depends upon

Closed by  Jerome Leclanche (Adys)
Saturday, 25 April 2015, 20:43 GMT
Reason for closing:  Fixed
Comment by Doug Newgard (Scimmia) - Monday, 02 March 2015, 14:44 GMT
Could you post more of the error? I'm not sure just what failed to start, so I'm not sure where the missing dep should be.
Comment by J W Hickman (jwhickman) - Tuesday, 03 March 2015, 05:16 GMT
Ah, you're referring to the application reporting the above error message...sorry about that.
---------
$ journalctl |grep xcb
Mar 01 19:58:54 xxx lxqt-session[312]: This application failed to start because it could not find or load the Qt platform plugin "xcb".
Available platform plugins are: eglfs, kms, linuxfb, minimal, minimalegl, offscreen, xcb.
Mar 01 19:59:04 xxx lxqt-session[338]: This application failed to start because it could not find or load the Qt platform plugin "xcb".
Available platform plugins are: eglfs, kms, linuxfb, minimal, minimalegl, offscreen, xcb.
---------

Thanks!
Comment by Jerome Leclanche (Adys) - Wednesday, 11 March 2015, 21:55 GMT
Does it work better with sddm instead of lxdm? lxdm is being phased out.
Comment by Jerome Leclanche (Adys) - Wednesday, 11 March 2015, 21:56 GMT
I'll try to fix this upstream. Give me some time.
Comment by J W Hickman (jwhickman) - Wednesday, 11 March 2015, 22:52 GMT
I had removed lxdm (which is how I intend to keep it actually, using startx with no display manager at all), and still had the issue. If you want me to test something out though, let me know. Thanks!
Comment by Jerome Leclanche (Adys) - Wednesday, 11 March 2015, 22:55 GMT
This is a bit of a weird issue. I talked to the opensuse maintainers and they confirmed libxkbcommon-x11 is not a dependency.
Comment by J W Hickman (jwhickman) - Thursday, 12 March 2015, 01:16 GMT
Perhaps its due to a double-dependency with "Available platform plugins are: eglfs, kms, linuxfb, minimal, minimalegl, offscreen, xcb." I am apparently using xcb on my Arch setup, but opensuse may be setup to require a different platform plugin, rather than them being 'optional.' Just a guess...
Thus, maybe one of the xcb libraries needs libxkbcommon-x11 added as an optional dependency? Not sure how an optional dependency's optional dependency (but required for certain package combinations) would get handled in Arch packages.
Comment by Antonio Rojas (arojas) - Thursday, 12 March 2015, 07:45 GMT
@Jerome libxkbcommon-x11 is required in Arch for all Qt5 apps with a GUI, see https://bugs.archlinux.org/task/41055 and https://bugs.archlinux.org/task/40468
Comment by Martin Stepanek (8B3CE273) - Saturday, 28 March 2015, 08:04 GMT
Same here, with fresh Arch installation, only with xorg, lxqt and openbox, I can't start start lxqt via startx due same issue. Installing libxkbcommon-x11 fixed my problem.
Comment by Frederik “Freso” S. Olesen (Freso) - Saturday, 25 April 2015, 20:17 GMT
I can verify too. Trying to login using lightdm as well as trying to start LXQt manually with "startlxqt" failed to work. Installing libxkbcommon-x11 made it work.
Comment by Jerome Leclanche (Adys) - Saturday, 25 April 2015, 20:43 GMT
This should be fixed in lxqt-session-0.9.0-2. Sorry for the delay.

Loading...