Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43947 - [plasma-workspace] DPI seems hardcoded to 96x96

Attached to Project: Arch Linux
Opened by Kiril Vladimiroff (Vladimiroff) - Wednesday, 25 February 2015, 12:50 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 20 September 2015, 06:01 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Felix Yan (felixonmars)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I have a MacBook Pro 11,3 (13-inch) with Retina display. KDE/Qt/GTK+ applications look as good as possible, but plasma and related applications (like desktop effects configuration screen) show fonts and icons pixelated.

Example:

Acording to xdpyinfo DPI is set correctly (and all apps respect that):

screen #0:
dimensions: 2560x1600 pixels (286x179 millimeters)
resolution: 227x227 dots per inch

Additional info:
* Qt 5.4.0
* KDE Frameworks 5.7.0
* Plasma 5.2.0
* Kernel 3.18.6
* I'm with Intel i5 (Haswell) with built-in video card

* Created brand-new user in order to make sure it's not a configuration issue

Steps to reproduce:
1. Install plasma 5.2 on a machine with HiDPI screen (MacBook Pro, X1 Carbon 3rd gen, ...)
2. Set the fonts DPI from System Settings -> Fonts -> Force fonts DPI to 124 or 144
3. Configure the screen DPI in X (https://wiki.archlinux.org/index.php/Xorg#Display_size_and_DPI)
4. Confirm it's set properly after restart (e.g. xdpyinfo | grep -B 2 resolution)
5. Confirm that all applications take these settings into account and look normal
6. Take a look at a plasma panel, widget, etc...

At first I thought it's an upstream issue, but I can't reproduce this on Kubuntu Live CD (same KDE and plasma versions).
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 20 September 2015, 06:01 GMT
Reason for closing:  Fixed
Comment by Ma Jiehong (jiehong) - Thursday, 30 April 2015, 13:14 GMT
With plasma 5.2, setting the dpi at 192 works fine for me without setting the DPI in X.

I don't have the pixelated issue you have on my 2880×1800 screen.
Comment by Antonio Rojas (arojas) - Saturday, 19 September 2015, 22:50 GMT
There have been lots of DPI fixes in recent Plasma versions, is this still an issue?
Comment by Kiril Vladimiroff (Vladimiroff) - Saturday, 19 September 2015, 23:51 GMT
Well, DPI reported by the X server is still 96x96, but this is a WONTFIX for them due to... questionable reasons. Plasma however handles high DPI flawlessly for quite some time, so this can be considered as resolved now.

Loading...