Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43860 - [syslog-ng] Version 3.6.2 segfaults with empty config file

Attached to Project: Arch Linux
Opened by Jérôme Vuarand (doub) - Tuesday, 17 February 2015, 17:48 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 05 April 2016, 16:12 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Eric Belanger (Snowman)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

syslog-ng is now systematically segfaulting when trying to start it. I didn't realize it until recently when I found my rotated log files were empty, so I don't know when the problem appeared.

Additional info:
* syslog-ng 3.6.2

Steps to reproduce:
* create /etc/syslog-ng/syslog-ng.conf with just the following line: @version: 3.6
* run /usr/bin/syslog-ng -F
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 05 April 2016, 16:12 GMT
Reason for closing:  Fixed
Additional comments about closing:  syslog-ng 3.6.3-2
Comment by Doug Newgard (Scimmia) - Tuesday, 17 February 2015, 18:03 GMT
So you deleted your config file then wonder why it won't work?
Comment by Jérôme Vuarand (doub) - Tuesday, 17 February 2015, 22:59 GMT
No, I had a full config file that worked one day and stopped working after an update. So I tried to isolate the directive causing the crash to provide an example easier to reproduce, and it turned out even with no directive at all in the config file the process still crashes.
Comment by Jérôme Vuarand (doub) - Tuesday, 30 June 2015, 01:42 GMT
I tried reverting the config file to the default provided in the package, and it still crashes on start. Any news on this issue?
Comment by Eric Belanger (Snowman) - Thursday, 30 July 2015, 01:55 GMT
Does syslog-ng-3.6.3-1 works fine?
Comment by Jérôme Vuarand (doub) - Thursday, 30 July 2015, 10:43 GMT
No, it's still crashing on startup. Just running "syslog-ng -s" (which should just parse the config file) crashes too.
Comment by Jens Adam (byte) - Friday, 31 July 2015, 02:56 GMT
No problem here (3.6.3, i686), -s works fine, as does starting, logging and stopping via syslog-ng.service.
Comment by Jérôme Vuarand (doub) - Friday, 31 July 2015, 09:20 GMT
I'm on x86_64 as indicated in the ticket details. I'm happy to provide any additional details you may request about hardware or other installed software.
Comment by Colton (frostyfrog) - Wednesday, 30 September 2015, 06:19 GMT
I am also seeing this, though I do have a bit more information to go off of. For instance, systemd reported that it crashed within libuuid. (I apologize for not uploading files instead. The open file dialog crashes my browser most of the time and I have yet to figure out why) Hopefully the logs below help out somewhat, and hopefully Flyspray doesn't mess them up. :) I'm using the latest and greatest on x86_64. I just updated my system and rebooted half an hour ago.

So that means my related package versions are:
syslog-ng 3.6.3-1
openssl 1.0.2.d-1
libutil-linux 2.27-2 (libuuid is in this one)
systemd 225-1.

Log from systemd:
Sep 30 00:16:44 Atlanta systemd[1]: Starting System Logger Daemon...
-- Subject: Unit syslog-ng.service has begun start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit syslog-ng.service has begun starting up.
Sep 30 00:16:45 Atlanta kernel: syslog-ng[2396]: segfault at 7fb8391c8010 ip 00007fb8391c8010 sp 00007fffc68856a8 error 14 in libuuid.so.1.3.0[7fb838fde000+1ff000]
Sep 30 00:16:45 Atlanta systemd[1]: syslog-ng.service: Main process exited, code=dumped, status=11/SEGV
Sep 30 00:16:45 Atlanta systemd[1]: Failed to start System Logger Daemon.
-- Subject: Unit syslog-ng.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit syslog-ng.service has failed.
--
-- The result is failed.


Tracestack from coredump:
(gdb) bt
#0 0x00007f41d027b010 in ?? ()
#1 0x00007f41d47343bc in SSL_COMP_get_compression_methods () from /usr/lib/libssl.so.1.0.0
#2 0x00007f41d473b1e0 in SSL_library_init () from /usr/lib/libssl.so.1.0.0
#3 0x00007f41d0294df1 in ?? () from /usr/lib/syslog-ng/libsyslog-ng-crypto.so
#4 0x00007f41df26827a in call_init.part () from /lib64/ld-linux-x86-64.so.2
#5 0x00007f41df26838b in _dl_init () from /lib64/ld-linux-x86-64.so.2
#6 0x00007f41df26c830 in dl_open_worker () from /lib64/ld-linux-x86-64.so.2
#7 0x00007f41df268124 in _dl_catch_error () from /lib64/ld-linux-x86-64.so.2
#8 0x00007f41df26bfd1 in _dl_open () from /lib64/ld-linux-x86-64.so.2
#9 0x00007f41dd645fc9 in ?? () from /usr/lib/libdl.so.2
#10 0x00007f41df268124 in _dl_catch_error () from /lib64/ld-linux-x86-64.so.2
#11 0x00007f41dd6465e1 in ?? () from /usr/lib/libdl.so.2
#12 0x00007f41dd646061 in dlopen () from /usr/lib/libdl.so.2
#13 0x00007f41de0c5982 in g_module_open () from /usr/lib/libgmodule-2.0.so.0
#14 0x00007f41deffbdd7 in ?? () from /usr/lib/libsyslog-ng-3.6.so.0
#15 0x00007f41deffc743 in plugin_load_candidate_modules () from /usr/lib/libsyslog-ng-3.6.so.0
#16 0x00007f41defe2974 in cfg_lexer_lex () from /usr/lib/libsyslog-ng-3.6.so.0
#17 0x00007f41df008229 in main_parse () from /usr/lib/libsyslog-ng-3.6.so.0
#18 0x00007f41defe0520 in cfg_run_parser () from /usr/lib/libsyslog-ng-3.6.so.0
#19 0x00007f41defe0717 in cfg_read_config () from /usr/lib/libsyslog-ng-3.6.so.0
#20 0x00007f41deff7199 in main_loop_read_and_init_config () from /usr/lib/libsyslog-ng-3.6.so.0
#21 0x00000000004016c3 in main ()
Comment by Jens Adam (byte) - Tuesday, 05 April 2016, 15:31 GMT
I guess this is fixed?
Comment by Jérôme Vuarand (doub) - Tuesday, 05 April 2016, 15:57 GMT
I just updated and the service now starts without crashing.

Loading...