Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43830 - [xorg-server] No video after update to xorg-server 1.17.1

Attached to Project: Arch Linux
Opened by Raphael Barabas (irgendwoanders) - Sunday, 15 February 2015, 14:19 GMT
Last edited by Laurent Carlier (lordheavy) - Thursday, 11 June 2015, 16:25 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 14
Private No

Details

Description:
Did a small update today. Most of it was due to https://www.archlinux.org/news/xorg-server-1171-is-now-available/
My Desktop PC does not boot into X anymore. No video signal.

If other users experience this as well, a workaround to get a usable system should be communicated in the news link above.

Additional info:
Intel i5 on a Intel Z97 board (intel onboard graphics shut off in bios)
Nvidia gtx 760 connected to monitor via DVI

I would need to connect via a VGA cable to check if video output is now vie the Intel card or not.
There is no special Xorg configuration on this machine.

Steps to reproduce:
See above for hardware environment.
1. pacman -Syu
2. reboot
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Thursday, 11 June 2015, 16:25 GMT
Reason for closing:  Fixed
Comment by Raphael Barabas (irgendwoanders) - Sunday, 15 February 2015, 14:44 GMT
Actually the onboard Intel graphics was enabled and not shut off as stated above.
This was not an issue before the update. Also, there is a video signal on the VGA output of the onboard card, but the screen stays black.

I was now able to solve the issue by disabling Intel onboard graphics in the BIOS. Now everything is handled by the Nvidia card again.
Comment by Laurent Carlier (lordheavy) - Sunday, 15 February 2015, 14:57 GMT
Do you have a xorg.conf file ? you can try removing it, also post your xorg log file
Comment by Raphael Barabas (irgendwoanders) - Sunday, 15 February 2015, 21:04 GMT
I do not have a configuration file in /etc/X11. Also, the latest logfile /var/log/Xorg.0.log dates back to Apr 14 2014.
Got it this way now: journalctl -b-2 |grep -i xorg > /tmp/Xorg.log

Xorg segfaults after loading some module called glamoregl. Is this module some sort of a fallback, maybe?
   Xorg.log (39.1 KiB)
Comment by AnAkkk (AnAkkk) - Sunday, 15 February 2015, 21:15 GMT
It's crashing for me too on an optimus laptop which was set up to only use the nvidia card. More people have the same issue here:
https://bbs.archlinux.org/viewtopic.php?id=193685

I've reverted to only use the intel card for now. The backtrace looked the same as yours.
Comment by Pablo Lezaeta (Jristz) - Sunday, 15 February 2015, 21:36 GMT
glamour as I know is related to intel and dri2 cappable graphics, so it work using only modesetting? (aka: only xorg-server intalled)
Comment by AnAkkk (AnAkkk) - Sunday, 15 February 2015, 21:39 GMT
modesetting uses glamor since xorg 1.17, and it's probably not compatible with nvidia driver, which is probably why it crashes.
Comment by Pablo Lezaeta (Jristz) - Sunday, 15 February 2015, 21:49 GMT
now sound more like mergin xf86-video-modesetting into xorg-server was a BAD idea for nvidia users.
Maybe resplit it or ship a xorg.conf with nvidia and in it having blacklisted the glamor, or make glamor separate from the rest and only intall it if needed.

the test now rely on try blacklist glamor in some way and try run the server again (and report upstream, maybe they could point a workaround).
Comment by Soup (Soup) - Monday, 16 February 2015, 13:06 GMT
It is indeed glamor. Terrible workaround but desperate times...:
> mv /usr/lib/xorg/modules/libglamoregl.so /usr/lib/xorg/modules/libglamoregl.so.fu

And X comes up nicely again.

It would be nice if it was split out of xorg-server
xorg-server /usr/lib/xorg/modules/libglamoregl.so
Comment by AnAkkk (AnAkkk) - Monday, 16 February 2015, 13:08 GMT
I don't think it needs to be split, you could still set

Option "AccelMethod" "none"

in your xorg.conf.

glamor is not used and that makes SDDM/Plasma starts for me, unfortunately X still ends up crashing while Plasma is loading, so it doesn't look like glamor is the only issue here.
Comment by Andreas Radke (AndyRTR) - Monday, 16 February 2015, 18:34 GMT
Intel driver should be used with SNA. Try setting this in your xorg.conf if defaults (without xorg.conf) fail.
Comment by AnAkkk (AnAkkk) - Monday, 16 February 2015, 18:37 GMT
We are talking about modesetting (in case of optimus setups), which doesn't have SNA, but now uses glamor. xf86-video-intel (SNA) is not used in such optimus setups.
https://wiki.archlinux.org/index.php/NVIDIA_Optimus#Using_nvidia
Comment by Raphael Barabas (irgendwoanders) - Wednesday, 18 February 2015, 21:43 GMT
The workaround to switch off intel onboard graphics in BIOS works fine for me and my use case. Not sure if it's worth the effort, ticket can be closed as far as I am concerned.
Comment by AnAkkk (AnAkkk) - Wednesday, 18 February 2015, 21:44 GMT
It's not possible to turn off the intel card on mine and for many people, which is why we need to use the xrandr commands and modify the xorg.conf file to get the nvidia card to be used.
Comment by George (Vash63) - Thursday, 19 February 2015, 07:15 GMT
Same issue here. I use my Nvidia as my primary and my BIOS does not allow the Intel to be disabled. It's an HTPC, power isn't an issue so I don't bother with bumblebee or anything like that, just want to use Nvidia for everything.
Comment by Matt Runion (mrunion) - Thursday, 19 February 2015, 14:04 GMT
@Raphael Barabas: I too have no option of disabling the Intel card in my BIOS, so I am forced to use the xrandr/modesetting route. I also use the laptop as a "desktop replacement", so I am not concerned about battery life on the machine. I want nVidia on all the time, always. (FWIW: If I had known that this machine had the Optimux setup, I would not have bought it.)
Comment by Jussi Sivonen (Jupelius) - Saturday, 21 February 2015, 14:51 GMT
I've been having same kind of issues. I also have Intel i5 and Z97 but my GPU is NVIDIA GTX 960.

I can get my system to work if I a) move the libglamoregl.so away from /usr/lib/xorg/modules or b) disable my onboard Intel GPU.

The file attached is my Xorg.log from a session with libglamoregl.so intact and Intel GPU enabled.

Having or not having xorg.conf didn't matter.
   gth (12.9 KiB)
Comment by Laurent Carlier (lordheavy) - Saturday, 21 February 2015, 16:35 GMT
wild guess, glamoregl try to work with libgl/libegl from nvidia, then kaboom!

You should fill a bug upstream with output of 'lspci -v', 'journalctl -k --no-pager' and content of Xorg.0.log file at https://bugs.freedesktop.org
Adding Option "AccelMethod" "none" to modesetting driver fix the problem (better than removing libglamoregl.so file), see https://wiki.archlinux.org/index.php/NVIDIA_Optimus#Using_nvidia

Please post the link from the upstream bug report here.

Comment by Earnestly (Earnest) - Saturday, 21 February 2015, 22:43 GMT
Just to make this clear for the bug report, this is not just on optimus machines.
Comment by AnAkkk (AnAkkk) - Wednesday, 25 February 2015, 20:59 GMT
This might be fixed by the latest nvidia driver:
https://devtalk.nvidia.com/default/topic/813885

"Fixed a bug that caused the X server to crash if a RandR 1.4 output provided by a Sink Output provider was selected as the primary output on X.Org xserver 1.17 and higher."
Comment by Erik (d-mon) - Thursday, 26 February 2015, 23:29 GMT
I'm using nvidia 346.35-6 and the bug in still present. Attaching my xorg.conf. I can also confirm that the temporary fix to rename /usr/lib/xorg/modules/libglamoregl.so works. Would this be the correct module to file the bugreport to? https://bugs.freedesktop.org/buglist.cgi?component=Driver%2Fglamor&product=xorg&resolution=---
Comment by Laurent Carlier (lordheavy) - Thursday, 11 June 2015, 13:30 GMT
Is it fixed with current nvidia/xorg?
Comment by Erik (d-mon) - Thursday, 11 June 2015, 16:22 GMT
It works for me now. No longer need to move/delete libglamoregl.so to start X. xorg 1.17.1-7 and nvidia 352.09-1

Loading...