Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43806 - [deluge] [python2-pyopenssl] missing optional dependency python2-service-identity

Attached to Project: Arch Linux
Opened by Justin Capella (justincapella) - Friday, 13 February 2015, 03:00 GMT
Last edited by Jan Steffens (heftig) - Friday, 13 February 2015, 15:45 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Jan Steffens (heftig)
Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

Optional dependency of python2-service-identity is required to make use of deluged/deluge-console, or user will see message similar to:

":0: UserWarning: You do not have a working installation of the service_identity module: 'No module named service_identity'. Please install it from <https://pypi.python.org/pypi/service_identity> and make sure all of its dependencies are satisfied. Without the service_identity module and a recent enough pyOpenSSL to support it, Twisted can perform only rudimentary TLS client hostname verification. Many valid certificate/hostname mappings may be rejected."


Additional info:
Name : deluge
Version : 1.3.11-1
Depends On : python2-xdg libtorrent-rasterbar python2-twisted python2-pyopenssl python2-chardet python2-setuptools
Optional Deps : python2-notify: libnotify notifications
pygtk: needed for gtk ui [installed]
librsvg: needed for gtk ui [installed]
python2-mako: needed for web ui

Not sure if the intent was to expect the user to inspect the optional dependencies of python2-twisted, but I did not, and then ran into problems, and had to investigate.

Steps to reproduce:
Install deluge, and optional dependencies
Run 'deluged' or 'deluge-console'
This task depends upon

Closed by  Jan Steffens (heftig)
Friday, 13 February 2015, 15:45 GMT
Reason for closing:  Not a bug
Additional comments about closing:  optdep is on python2-twisted, as is proper.

Loading...