Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43759 - Updating libiodbc fails due to missing/wrong key

Attached to Project: Community Packages
Opened by Michael Gerdau (mgd) - Monday, 09 February 2015, 23:31 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 10 February 2015, 16:47 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: When I try to update the newly updated libiodbc-3.52.9-2 on my system I get an error 'key "A6234074498E9CEE" could not be looked up remotely'.


Additional info:
2 weeks ago (or so) I did as instructed at https://www.archlinux.org/news/gnupg-21-and-the-pacman-keyring/

Steps to reproduce: pacman -S libiodbc
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 10 February 2015, 16:47 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#42798 
Comment by Karol Błażewicz (karol) - Tuesday, 10 February 2015, 00:25 GMT
Works fine here:

$ sudo pacman -S libiodbc
resolving dependencies...
looking for conflicting packages...
Package (1) New Version Net Change Download Size
community/libiodbc 3.52.9-2 0.68 MiB 0.16 MiB
Total Download Size: 0.16 MiB
Total Installed Size: 0.68 MiB
:: Proceed with installation? [Y/n]
:: Retrieving packages ...
libiodbc-3.52.9-2-i686 160.2 KiB 496K/s 00:00 [###################################] 100%
(1/1) checking keys in keyring [###################################] 100%
downloading required keys...
:: Import PGP key 2048R/02FD1C7A934E614545849F19A6234074498E9CEE, "Christian Hesse (Arch Linux Package Signing) <arch@eworm.de>", created: 2011-08-12? [Y/n]
(1/1) checking package integrity [###################################] 100%
(1/1) loading package files [###################################] 100%
(1/1) checking for file conflicts [###################################] 100%
(1/1) checking available disk space [###################################] 100%
(1/1) installing libiodbc [###################################] 100%
Comment by Maurizio D'Addona (mauritiusdadd) - Tuesday, 10 February 2015, 06:44 GMT
Hi, I have the same problem on my Arch x86_64.
I tried to remove the package from the cache and redownload it then I reinstalled archlinux-keyring,
removed the directory /etc/pacman.d/gnupg and run pacman-key --init && pacman-key --populate.
The key however is correct because I can donwload it using my user's gpg but when I try to use
pacman-key to manually fetch the key, it fails with the following error:

# pacman-key --recv-keys A6234074498E9CEE
gpg: connecting dirmngr at '/root/.gnupg/S.dirmngr' failed: IPC connect call failed
gpg: keyserver receive failed: No dirmngr
==> ERROR: Remote key not fetched correctly from keyserver.

Maybe it is releated with the following bug: https://bugs.archlinux.org/task/42798

-- EDIT --
removing /root/.gnupg and then recreating it with gpg seems to solve the problem
Comment by Michael Gerdau (mgd) - Tuesday, 10 February 2015, 15:31 GMT
Good finding Maurizio.

I had no /root/.gnupg on my system. After I issued a "mkdir /root/.gnupg" as user root I could install libiodbc with pretty much the same behaviour as has been described by Karol as of above.

Loading...