Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43733 - [tlp] 0.7-1 conflicts with netctl and leaves it unusable

Attached to Project: Community Packages
Opened by Martin Schnitkemper (Martin-MS) - Saturday, 07 February 2015, 22:23 GMT
Last edited by Maxime Gauduin (Alucryd) - Sunday, 08 February 2015, 16:21 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Maxime Gauduin (Alucryd)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description: After upgrade to 0.7-1 netctl can't establish a wifi connection

Additional info: I use netctl to establish network connections; NetworkManager is installed as a dependency. Since version 0.7-1 tlp starts the NetworkManager.service and netctl fails to start. In result I lost the network connection. The only solution so far is to mask NetworkManager or to disable netctl and enable NetworkManager. That makes netctl unusable if tlp is installed. For other reasons I prefer to keep netctl instead of NetworkManager.

* package version(s): 0.7-1

Steps to reproduce: Upgrade to 0.7-1 triggers the problem, de-installation (or probably a downgrade) solved it.
This task depends upon

Closed by  Maxime Gauduin (Alucryd)
Sunday, 08 February 2015, 16:21 GMT
Reason for closing:  Not a bug
Comment by Maxime Gauduin (Alucryd) - Sunday, 08 February 2015, 16:21 GMT
NetworkManager is not a dependecy of tlp, it is a dep of tlp-rdw which is completely optional and is the only part that needs NetworkManager to operate. The tlp unit only "Wants" NetworkManager, meaning it will still start and work fine even if NetworkManager is not available.

Loading...