Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43714 - makepkg -S fails when using architecture specific sources with the same name in the PKGBUILD

Attached to Project: Arch Linux
Opened by H. Giskard Reventlov (Reventlov) - Thursday, 05 February 2015, 22:05 GMT
Last edited by Dave Reisner (falconindy) - Thursday, 05 February 2015, 22:31 GMT
Task Type Bug Report
Category Arch Projects
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
When using makepkg -S with a PKGBUILD that contains architecture specific sources such as source_i686 and source_x86_64 that are named the same (for example, http://foo.bar/i686/1 and http://foo.bar/x86_64/1), the checksum on one of the source fails. I'm not sure if this is a bug or not.


Additional info:
* package version(s): makepkg (pacman) 4.2.0

Steps to reproduce:
Try to do a makepkg -S on the PKGBUILD attached. Output from multiple commands attached.
This task depends upon

Closed by  Dave Reisner (falconindy)
Thursday, 05 February 2015, 22:31 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Working as intended, see comments.
Comment by Dave Reisner (falconindy) - Thursday, 05 February 2015, 22:19 GMT
It's a bug in your PKGBUILD. You'll need to rename the sources appropriately with whatever:: prefixing in the source arrays.
Comment by H. Giskard Reventlov (Reventlov) - Thursday, 05 February 2015, 22:22 GMT
But, if i do that, i'd have to separate different cases during the package function, right ? Doesn't that "defeat" the purpose of having architecture specific sources for cleanliness ?
Comment by Dave Reisner (falconindy) - Thursday, 05 February 2015, 22:26 GMT
I guess you would, but I don't really see that as a problem that PKGBUILD needs to solve. You don't need architecture-specific sources to encounter this problem either. Consider:

source=(http://www.example.com/foo.tar.gz http://www2.example.com/foo.tar.gz)

Granted, your code doesn't need to diverge to handle this, but the point of arch-specific attributes was to make the metadata converge, not the code in the build functions.
Comment by H. Giskard Reventlov (Reventlov) - Thursday, 05 February 2015, 22:30 GMT
Ok, thank you for the answers. You can consider this request as closed, from my point of view.

Loading...