Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43663 - [grub] Enabling GRUB_ENABLE_CRYPTODISK creates additional "cryptomount -u" entries

Attached to Project: Arch Linux
Opened by MM (marcomarco) - Sunday, 01 February 2015, 20:18 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Tuesday, 29 March 2016, 01:58 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

As the subject says, when setting GRUB_ENABLE_CRYPTODISK=y in /etc/default/grub bogus "cryptomount -u" lines are added in the generated grub.cfg, due to this the boot will stop with an 'error: device required' message until the user presses enter to continue

Additional info:
* package version(s): 1:2.02.beta2-5

Steps to reproduce:
Set the GRUB_ENABLE_CRYPTODISK=y option and then run grub-mkconfig, there should be some "cryptomount -u" lines with no crypto UUID in the generated cfg file

Fix:
See http://lists.gnu.org/archive/html/grub-devel/2014-12/msg00055.html this small patch by Andrei Borzenkov to grub-mkconfig_lib fixes the issue for me (removing the "" in the for), not sure if this patch has made it in grub proper but I thought I'd open a bug report so this can be evaluated for having in the Arch package
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Tuesday, 29 March 2016, 01:58 GMT
Reason for closing:  Upstream
Comment by Ingo Albrecht (indigo) - Monday, 20 April 2015, 11:32 GMT

Loading...