Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43657 - [kde-gtk-config-frameworks] systemsettings applet fails to run

Attached to Project: Arch Linux
Opened by Rulatir (Rulatir) - Sunday, 01 February 2015, 15:13 GMT
Last edited by Andrea Scarpino (BaSh) - Sunday, 01 February 2015, 15:25 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

My understanding is that kde-gtk-config-frameworks is the kf5 replacement for kde-gtk-config, and it should provide the "GTK Styles and Fonts" control module for systemsettings5 just as the old kde-gtk-config provided it for the KDE4 systemsettings.

This does not happen. On my system kde-gtk-config is NOT installed, kde-gtk-config-frameworks IS installed, and when I choose the "GTK Styles and Fonts" control module, it shows the following message instead of the module's UI (screenshot attached):

-------------------------------------------------
The shared library was not found.

Possible reasons:

* An error occured during your last KDE update leaving an orphaned control module
* You have old third party modules lying around

Check these points carefully and try to remove the module mentioned in the error message. If this fails, consider contacting your distributor or packager.
--------------------------------------------------

I understand that the "error message" is just "The shared library was not found" - nothing more informative than that. I tried removing both the old and new kde-gtk-config(-frameworks)? package, and the control module still shows in systemsettings, so apparently that is not the right way to "remove the module"; besides, I *want* the module there and working.

I am therefore "contacting my distributor/packager" via this bugtracker.

Additional info:
* package version(s)

kde-gtk-config-frameworks: 5.2.0-1
systemsettings: 5.2.0-1

Steps to reproduce:

1) Run systemsettings5
2) Try using the GTK Styles and Fonts control module
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Sunday, 01 February 2015, 15:25 GMT
Reason for closing:  Not a bug
Additional comments about closing:  See comments
Comment by Rulatir (Rulatir) - Sunday, 01 February 2015, 15:24 GMT
OUCH nevermind. The new control module - the correct one - is located elsewhere in the tree. There's still this old GTK Styles and Fonts module dangling but it can't do any harm because it doesn't even run.

Loading...