Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43625 - [systemd] segfaults since 218

Attached to Project: Arch Linux
Opened by Geert Hendrickx (ghen) - Thursday, 29 January 2015, 13:10 GMT
Last edited by Dave Reisner (falconindy) - Sunday, 15 February 2015, 16:46 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Thomas B├Ąchler (brain0)
Dave Reisner (falconindy)
Tom Gundersen (tomegun)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Various systemd tools segfault since update to systemd 218-1

- "systemctl" (no arguments) segfaults ("systemctl status" works though)
- ssh+console login is impossible due to systemd-logind segfault
- kernel prints "invalid opcode: 0000 [#91] SMP"

rollback to systemd 217-8 fixed the problem.

This is on an i686 VPS. All packages are up to date, the problem started since systemd upgrade + reboot, and fixed since systemd downgrade + manual systemd-logind restart.

This task depends upon

Closed by  Dave Reisner (falconindy)
Sunday, 15 February 2015, 16:46 GMT
Reason for closing:  Won't fix
Additional comments about closing:  Specific to a VPS provided kernel.
Comment by Dave Reisner (falconindy) - Thursday, 29 January 2015, 13:30 GMT
Please install debug symbols and provide proper backtraces of the crashes. I provide symbols in a separate repo:

[falconindy]
Server = http://repo.falconindy.com/$repo/os/$arch
Comment by Geert Hendrickx (ghen) - Thursday, 29 January 2015, 13:57 GMT
It seems none of the systemd binaries wants to core dump, despite ulimit -c unlimited? (other processes sent SIGSEGV do dump core)
Comment by Dave Reisner (falconindy) - Thursday, 29 January 2015, 14:02 GMT
You don't need a coredump, just a backtrace.

$ gdb systemctl
set height 0
run
bt full
Comment by Geert Hendrickx (ghen) - Thursday, 29 January 2015, 14:10 GMT
Tried that too: no stack.

(gdb) set height 0
(gdb) run
Starting program: /usr/bin/systemctl
warning: Could not load shared library symbols for linux-gate.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".

Program terminated with signal SIGSEGV, Segmentation fault.
The program no longer exists.
(gdb) bt full
No stack.
(gdb)
Comment by Geert Hendrickx (ghen) - Thursday, 29 January 2015, 14:21 GMT
Btw, even with the bad systemd-logind, when attaching strace to sshd, I can login succesfully (but with a long delay).
Comment by Geert Hendrickx (ghen) - Thursday, 29 January 2015, 16:06 GMT
The problem does not show with more recent kernel 3.16 provided by VPS hoster (previously 3.13).
Comment by Dave Reisner (falconindy) - Thursday, 29 January 2015, 18:47 GMT
Then the problem is with your VPS host, not with Arch's systemd package.
Comment by Geert Hendrickx (ghen) - Sunday, 01 February 2015, 08:08 GMT
Do you want to investigate this further (as it coincides with systemd 218 upgrade), otherwise I just proceed with newer kernel and close this ticket?

Loading...