Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#43601 - [networkmanager] eduroam - can not start DHCP client

Attached to Project: Arch Linux
Opened by abc (Xiflite) - Tuesday, 27 January 2015, 22:32 GMT
Last edited by Jan de Groot (JGC) - Monday, 25 December 2017, 23:04 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

Description:
- try to connect to eduroam (http://en.wikipedia.org/wiki/Eduroam) - PEAP with MSVCHAPv2
- get a loop of "connecting", "dhcp client could not be started" and "disconnected"


Additional info:
only 1.0.0-1 effected - downgrade solves this problem immediately

This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 25 December 2017, 23:04 GMT
Reason for closing:  Fixed
Additional comments about closing:  internal dhcp client is default now, so this should work as dhcpcd is not used by default now.
Comment by Peter Harkins (pushcx) - Wednesday, 28 January 2015, 17:05 GMT
I also had this bug connecting to two WPA2 networks; downgrading to 0.9.10.0-4 (the previous version) also fixed it for me.

I was only able to downgrade because I was able to connect to a third WPA2 network for 3-4 minutes at a time (after that it would disconnect and fail to reconnect, not even getting to the dhcp stage).

Here's my wifi card from lspci -vv:

04:00.0 Network controller: Intel Corporation Wireless 7265 (rev 59)
Subsystem: Intel Corporation Dual Band Wireless-AC 7265
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 46
Region 0: Memory at f1000000 (64-bit, non-prefetchable) [size=8K]
Capabilities: <access denied>
Kernel driver in use: iwlwifi
Comment by Peter Harkins (pushcx) - Wednesday, 28 January 2015, 20:29 GMT
I think this is this bug: https://bugzilla.gnome.org/show_bug.cgi?id=743599
Which may be a dupe of this bug: https://bugzilla.gnome.org/show_bug.cgi?id=743472

For anyone who sees this, the answer is to downgrade, use dhclient instead of dhcp (install dhclient and make sure you don't have "dhcp=dhcp" in /etc/NetworkManager/Networkmanager.conf; NM tests for it before falling back to dhcp), or to wait for a future version of NetworkManager: they plan to drop their dhcpcd backend in favor of an internal dhcp implementation.
Comment by abc (Xiflite) - Wednesday, 28 January 2015, 20:36 GMT
Thx @pushcx

Reading this https://bugzilla.gnome.org/show_bug.cgi?id=743472#c9 let me propose to make networkmanager dependent on dhclient and not on "dhcp-client" until they drop support for both and use their own implementation.
Comment by Christian Bürckert (Kriese) - Sunday, 01 February 2015, 09:10 GMT
Same Problem but affecting also WPA2 Networks.
Downgrade to 0.9.10.0-4 works for me.
sudo pacman -U /var/cache/pacman/pkg/networkmanager-0.9.10.0-4-x86_64.pkg.tar.xz
Also disabling networkmanager and connecting over wifi-menu.
Comment by abc (Xiflite) - Sunday, 01 February 2015, 17:07 GMT
@Kriese You may try dhclient instead of dhcpcd.
Comment by Christian Bürckert (Kriese) - Sunday, 01 February 2015, 22:11 GMT
I had dhclient installed. I'll recheck on friday :)
Comment by Stefan Agner (falstaff) - Friday, 06 February 2015, 21:07 GMT
I suffered this issue too with a standard WPA2 Wi-Fi. With dhclient installed (and explicitly selected in /etc/NetworkManager/NetworkManager.conf using dhcp=dhclient) NetworkManager works fine again.

Fwiw, I posted the log output of my system in a forum thread:
https://bbs.archlinux.org/viewtopic.php?pid=1500473
Comment by abc (Xiflite) - Saturday, 07 February 2015, 13:51 GMT
@JGC @heftig
Why don't we make networkmanager dependent on dhclient (not on "dhcp-client") until they drop support for both and use their own implementation? That would fix this issue.
Comment by Christian Bürckert (Kriese) - Monday, 09 February 2015, 07:29 GMT
Installing dhclient solved the issue for me too. I would also suggest to add this dependency.

Loading...